Quick Reference Guide

506 PowerConnect B-Series TI24X Configuration Guide
53-1002269-02
Multicast Source Discovery Protocol (MSDP)
19
Filtering MSDP source-group pairs
The following commands allow you to filter individual source-group pairs in MSDP Source-Active
messages:
sa-filter in – Filters source-group pairs received in Source-Active messages from an MSDP
neighbor
sa-filter originate – Filters source-group pairs in Source-Active messages in advertisements to
an MSDP neighbor
Filtering incoming source-active messages
The following example configures filters for incoming Source-Active messages from three MSDP
neighbors:
For peer 2.2.2.99, all source-group pairs in Source-Active messages from the neighbor are
filtered out (dropped).
For peer 2.2.2.97, all source-group pairs except those with 10.x.x.x as the source are
permitted.
For peer 2.2.2.96, all source-group pairs except those associated with RP 2.2.42.3 are
permitted.
Example
The following commands configure an IP address on port 3/1. This is the port on which the MSDP
neighbors will be configured.
PowerConnect(config)# interface ethernet 3/1
PowerConnect(config-if-3/1)# ip address 2.2.2.98/24
PowerConnect(config-if-3/1)# exit
The following commands configure a loopback interface. The Layer 3 Switch will use this interface
as the source address for communicating with the MSDP neighbors.
PowerConnect(config)# interface loopback 1
PowerConnect(config-lbif-1)# ip address 9.9.9.8/32
PowerConnect(config-lbif-1)# exit
The following commands configure extended ACLs. The ACLs will be used in route maps, which will
be used by the Source-Active filters.
The following commands configure the route maps.
The following commands enable MSDP and configure the MSDP neighbors on port 3/1.
PowerConnect(config)# access-list 123 permit 10.0.0.0 0.255.255.255 any
PowerConnect(config)# access-list 124 permit 2.2.42.3 0.0.0.0 any
PowerConnect(config)# access-list 125 permit any any
PowerConnect(config)# route-map msdp_map deny 1
PowerConnect(config-routemap msdp_map)# match ip address 123
PowerConnect(config-routemap msdp_map)# exit
PowerConnect(config)# route-map msdp2_map permit 1
PowerConnect(config-routemap msdp2_map)# match ip address 125
PowerConnect(config-routemap msdp2_map)# exit
PowerConnect(config)# route-map msdp2_rp_map deny 1
PowerConnect(config-routemap msdp2_rp_map)# match ip route-source 124
PowerConnect(config-routemap msdp2_rp_map)# exit