HP-UX HB v13.00 Ch-22 - Performance and Tuning

HP-UX Handbook Rev 13.00 Page 5 (of 19)
Chapter 22 Performance & Tuning
October 29, 2013
configuration under problem conditions. Samples should be of sufficient length and granularity
to allow a statistically significant sample. As problems root cause may not be clear, it is prudent
to capture a wide scope of data to analyze for potential resource contention .
Memory issues :
swapinfo -tam
vmstat -n 60 20
ps -elf |sort -rnk 10
sar -b 5 120
CPU
sar -Muq 5 120
ps -elf |sort -rnk 8
System Tables
sar -v 10 60
OS configuration :
kctune -v ( if 11.11 kmtune)
more /etc/fstab
bdf -i
Memory
HP-UX utilizes both physical memory, RAM and disk memory, referred to as swap. While there
are a number of recommendations for memory sizing , the following is a practical guideline:
There should sufficient RAM to run all concurrent process and threads in RAM
There should be sufficient device swap to capture a minimum crash dump (25% of RAM)
There should be a sufficient quantity of device swap to cover all initial fork calls , i.e.
process reserve memory .
The Global System Memory Map is comprised of the systems physical memory and configured
swap.
The total address space for 32-bit architecture is 4 GB. For 64- bit, the kernel has access to 16
Terabytes out of 4 Exabytes. Although the 64-bit kernel in wide mode has 64-bit addressing
capability, currently only 42 out of the possible 64 bits are used. This leaves gaps represented in
the graphs below as shaded regions.
This space is broken down into four equal size sections called quadrants. No memory segment
may cross a quadrant boundary. For 32 bit no single process can access larger than 1GB of
address space. For 64 bit , while the address space is considerably larger, however no process
can access larger than 1 quadrant of address space.