aries.5 (2010 09)

a
ARIES(5) ARIES(5)
(HP Integrity Systems Only)
Example: ARIES Resource Configuration File
To execute a 32-bit PA-RISC application
hello_world through ARIES using 32 MB of stack, you can
place an
.ariesrc file containing the following line in user’s home directory or in the root (
/)directory.
/user/foo/hello_world -ssz 32768
Alternatively, if the following line is specified, the stack size of 32 MB will be applied to all 32-bit
PA-RISC applications invoked by the user or by all users depending on ARIES RC file being placed in
user’s home directory or in the root directory.
/ -ssz 32768
Sample ARIES resource configuration files are shown below. You can modify them to suit your require-
ments.
An example of user’s private ARIES RC file, located in his/her home directory
/home/user1/bin/*app -ssz 24576 -heap_ssz 32768
/home/user1/app2* -core_format v1 -corepid
/home/user1/*/app3 -reset_all -mem_order
/home/user1/dll/bin/* -osinc 256 -issz 1024 -ts 10
/home/user1/app5 -pa_os_cpu
/usr/bin/X11/xterm -ssz 24576 -heap_ssz 32768 -ap_heap_ssz 10240
/usr/local/bin/* -sched_trace -osinc 256 -issz 3072 -nomore
*/* -corepid
An example of an application specific ARIES RC file, placed in application’s installation directory
/opt/App/bin/* -reset_all -corepid -ssz 32768 -ts 10
/opt/App/bin/g* -reset_all -issz 4096 -heap_ssz 65536
/opt/App/bin/ab* -reset_all -heap_ssz 32768 -ap_heap_ssz 8196
/opt/App/bin/gcov -reset_all -mem_order
/opt/App/* -nomore
An example of a system wide global ARIES RC file, located in the root (
/)directory
/ -corepid
/usr/bin/app1 -osinc 256 -issz 1024 -ts 10
/usr/local/bin/* -core_format v1
/opt/App/*/app3 -mem_order
/usr/local/*/bin/xv -ssz 24576 -heap_ssz 32768 -ap_heap_ssz 5120
ARIES MEMORY MANAGEMENT
ARIES Managed Area (AMA)
ARIES consumes a small amount of memory (called ARIES Managed AREA (AMA)) towards the end of
the PA-RISC application’s private data segment. AMA is reserved exclusively for ARIES use by the
Integrity HP-UX operating system. The AMA size is decided by these kernel tunable parameters:
pa_maxssiz_32bit for 32-bit ARIES
pa_maxssiz_64bit for 64-bit ARIES
See pa_maxssiz (5) for more details.
The Integrity HP-UX OS passes a pointer
load_info to a structure of type load_info_t defined in
/usr/include/crt0.h, to ARIES. The start and end of AMA are marked by
load_info->li_priv_mmf_start and load_info->li_bstore_start
respectively. ARIES
uses AMA to store following data:
1. ARIES’s initialized data, un-initialized data (BSS) and thread local storage (TLS).
2. ARIES heap for internal
malloc() calls and for creating ARIES threads for emulation of PA-RISC
application’s threads.
3. PA-RISC application’s stack.
4. Translated code buffer (code cache region).
5. Data structures to access and manage the translated code blocks.
6. AMAP data structures for mapping of PA-RISC basic blocks and translated code block addresses.
10 Hewlett-Packard Company 10 HP-UX 11i Version 3: September 2010