aries.5 (2010 09)

a
ARIES(5) ARIES(5)
(HP Integrity Systems Only)
The rest of the debugging operations are the same as that on the PA-RISC HP-UX platform. All com-
mands of the gdb debugger are supported subject to limitations listed under the Limitations of PA-RISC
GDB Support section in this manpage.
Attaching PA-RISC GDB to PA-RISC process under ARIES
An already running PA-RISC process can be debugged on Integrity systems by attaching PA-RISC
debugger
gdb, using following steps:
1. Perform the preparatory steps as described above for debugging PA-RISC application under ARIES
using PA-RISC
gdb.
2. Invoke
gdb as follows:
$
gdb PA-RISC_executable PA-RISC_processID
After debugging is finished, perform the following steps.
1. Unset the environment variable
PA_DEBUG.
2. Restore the original value of the
SHELL environment variable.
Limitations of PA-RISC GDB Support
The limitations of PA-RISC
gdb emulation under ARIES are as follows:
1. No support for debuggers other than PA-RISC HP-UX
gdb
for debugging PA-RISC applications on
Integrity systems.
2. No support for old
gdb versions (of HP-UX 10.20 and earlier). However, debugging of HP-UX 10.20
applications using a HP-UX 11.0 (and newer) PA-RISC gdb is supported.
3. PA-RISC
gdb behaves differently for child processes created using
fork() and vfork() system
calls. ARIES emulates
vfork() and fork() system calls identically. The exact behavior shown by
PA-RISC gdb under ARIES may differ from that on a native PA-RISC HP-UX system.
4. If the debugged process is blocking in a system call, any attempt to get to the
gdb command prompt
by pressing ctrl-C does not work. The process needs to be killed from a different shell.
5. ARIES does not provide true emulation of MxN threads, and thus does not support debugging of
PA-RISC applications that are linked with pthreads library and create threads in MxN model.
NOTE: The PA-RISC applications linked with MxN pthreads library are emulated under ARIES as
traditional 1x1 threads, and thus can only be debugged under ARIES as any other non-MxN multi-
threaded application. Refer to the EMULATION OF MxN THREADS UNDER ARIES section in this
manpage for more information.
6. ARIES supports debugging of 32-bit and 64-bit PA-RISC HP-UX applications using 32-bit PA-RISC
HP-UX
gdb. 64-bit PA-RISC HP-UX gdb
is not supported under ARIES.
Generation of PA-RISC HP-UX Compatible Core File
ARIES supports creation of PA-RISC HP-UX compatible core files on Integrity systems. The size of the
core file is limited by
ulimit() and/or setrlimit() values. See ulimit (2) and setrlimit (2).
The PA-RISC application core file generated by ARIES will have the name as
core.PA-
RISC_application_name.
The PA-RISC HP-UX debugger is required to debug application core file generated by ARIES on an
Integrity system. Alternately, the application’s core file can be transferred to a PA-RISC system and
debugged using a PA-RISC debugger. Refer to
gdb help on the packcore command.
After ARIES has successfully written a core file for the PA-RISC application, it will print the following
message on
stderr:
[HP ARIES32/64]: Core file for 32/64-bit PA-RISC application
[HP ARIES32/64]: %s saved to path/core.PA_application_name
If the resulting core file is named as core or core.pid, it will be an ARIES core file, not useful for
application debugging.
The ARIES-generated PA-RISC HP-UX compatible core file is recognized by the
file command on
PA-RISC and Integrity HP-UX systems. See file (1).
2 Hewlett-Packard Company 2 HP-UX 11i Version 3: September 2010