aries.5 (2010 09)

a
ARIES(5) ARIES(5)
(HP Integrity Systems Only)
with release version of the Integrity HP-UX systems. Disabling (
-nocompat_core
) this
option flag will result in core files which may not work with
gdb from an older PA-RISC
HP-UX (11i version 1 and earlier) platform. Such core files need to be debugged using
gdb
from PA-RISC HP-UX 11i version 2 and later.
The default state of this option flag is enabled (
-compat_core).
-[no]corepid
[Disables] enables appending of the process ID to the PA-RISC application core file name. See
also getpid (2).
If this option flag is enabled (
-corepid), the core file name will be core.PA-
RISC_application_name.PID
.
The default state of this option flag is disabled (
-nocorepid).
-[no]fpsr_trans
[Disables] enables the dynamic translation of PA-RISC basic blocks that access and modify the
Floating Point Acess Regiser (FPSR : fr0L) frequently.
The default state of this option flag is disabled (
-nofpsr_trans).
-[no]help
[Disables] enables the printing of ARIES options and their minimum, maximum, and default
values on stderr. If this option flag is enabled (-help) ARIES will exit after printing the
available options.
The default state of this option flag is disabled (
-nohelp).
-[no]mem_fence
[Disables] enables the generation of memory fence mf instruction in translation for ordered
memory operations of PA-RISC application.
WARNING: Enabling (
-mem_fence) this option flag will slow down the performance of
memory loads in ARIES translated code. Enable (-mem_fence) this option flag only if the
PA-RISC application expecting strong memory ordering (program uses volatile variables)
fails under ARIES.
NOTE: Enabling the ARIES option flag
-mem_order does not automatically enable
(-mem_order) this option flag.
The default state of this option flag is disabled (
-nomem_fence).
-[no]mem_min
[Disables] enables the minimum memory footprint (process resident memory size) under
ARIES. Enabling (-mem_min) this option flag is useful for applications that have constraints
on process memory footprint. If this option flag is enabled (-mem_min), the sizes of all ARIES
memory segments are set to their minimum values.
WARNING: Enabling (
-mem_min) this option flag may cause performance slowdown due to
increased number of ARIES translation code buffer flushes.
The default state of this option flag is disabled (
-nomem_min).
-[no]mem_order
[Disables] enables the strong memory ordering in ARIES. You should enable (-mem_order)
this option flag only when your PA-RISC application expecting strong memory ordering fails
under ARIES. Such an application would be the one, which does not use memory ordering
semantics like ,O completer in load/store instructions or volatile cast in high level
code, and still expects strong memory ordering.
WARNING: Enabling (
-mem_order) this option flag may cause 2x-3x performance slow-
down.
The default state of this option flag is disabled (
-nomem_order).
-[no]opt_fpgr
[Disables] enables the mapping of the emulated FP (Floating Point) register context on general
register stack. The performance of the floating point intensive PA-RISC applications may be
better if this option flag is enabled (-opt_fpgr).
HP-UX 11i Version 3: September 2010 5 Hewlett-Packard Company 5