aries.5 (2010 09)

a
ARIES(5) ARIES(5)
(HP Integrity Systems Only)
-descsz { size | default }
Size in kbytes of the memory area for ARIES internal data structures (code cache descriptors)
for accessing and managing translated code blocks.
Value 32-bit ARIES 64-bit ARIES
Default: 8192 KB ( 8 MB) 8192 KB ( 8 MB)
Max: 32768 KB (32 MB) 65536 KB (64 MB)
Min: 4096 KB ( 4 MB) 4096 KB ( 4 MB)
NOTE: To minimize the performance drop due to increased frequency of ARIES code cache
descriptor area overflow, HP recommends setting this option value at default or maximum.
For optimal performance, a ratio of 1:2:2 should be maintained for the values of the ARIES
options:
-descsz, -amapsz, and
-ccsz.
-exc_dynt_heap_ssz
{ size | default }
Size in kbytes of the memory area for shared use by dynamic translator internal memory allo-
cation and alternate ARIES heap for memory allocation during signal handling.
Value 32-bit ARIES 64-bit ARIES
Default: 5120 KB (5 MB) 8192 KB ( 8 MB)
Max: 8192 KB (8 MB) 16384 KB (16 MB)
Min: 5120 KB (5 MB) 5120 KB ( 5 MB)
-heap_ssz { size | default }
Size in kbytes of the ARIES heap used for ARIES’s own
malloc() calls and to allocate space
for ARIES thread creation.
The ARIES heap is divided into two parts. The first part is used as ARIES private heap whose
size is determined by the option
-ap_heap_ssz. The remaining area from the ARIES heap
is used to allocate memory for the new threads.
Value 32-bit ARIES 64-bit ARIES
Default: 22528 KB (22 MB) 131072 KB (128 MB)
Max: variable variable
Min: 8192 KB ( 8 MB) 16384 KB ( 16 MB)
The values above are shown with the default values of kernel tunable parameters,
pa_maxssiz_32bit and pa_maxssiz_64bit, for 32-bit and 64-bit ARIES respectively.
With increased values of the respective kernel tunable parameters, the maximum value of
ARIES heap is computed as follows:
32-bit ARIES:
Max heap_ssz =pa_maxssiz_32bit-ssz-ccsz-amapsz -descsz-exc_dynt_heap_ssz-5 MB
64-bit ARIES:
Max heap_ssz =pa_maxssiz_64bit-ssz-ccsz-amapsz -descsz-exc_dynt_heap_ssz-24 MB
-issz { size | default }
Size in kbytes of the initially allocated stack for PA-RISC applications.
Value 32-bit ARIES 64-bit ARIES
Default: 64 KB 64 KB
Max: ssz value ssz value
Min: 32 KB 32 KB
At process startup time, ARIES computes the minimum value of
-issz by adding the sizes of
argument strings, environment variable strings, and keybits structure. If the computed value
is greater than -issz value, then ARIES increases this value accordingly.
-load file_name
Load the dynamically translated code from file_name at process startup time. This option can
optimize ARIES time spent in dynamic translations. Refer to the option -save for storing the
ARIES dynamic translations to a file.
8 Hewlett-Packard Company 8 HP-UX 11i Version 3: September 2010