glossary.9 (2010 09)

p
glossary(9) glossary(9)
channeled directly into the standard input of the command on the right.
portable file name character set
The following set of graphical characters are portable across conforming implementations of IEEE Stan-
dard P1003.1:
ABCDEFGHIJKLMNOPQRSTUVWXYZ
abcdefghijklmnopqrstuvwxyz
01234567890._-
The last three characters are the dot, underscore and hyphen characters, respectively. The hyphen
should not be used as the first character of a portable file name.
position-independent code (PIC)
Object code that can run unmodified at any virtual address. Position-independent code can use PC-
relative addressing modes and/or linkage tables. It is most often used in shared libraries, in which case
the linkage tables are initialized by the dynamic loader. Position-independent code is generated when
the
+z or +Z compiler option is specified.
privileged groups
A privileged group is a group that has had a
setprivgrp (see getprivgrp (2)) operation performed on
it, giving it access to some system calls otherwise reserved for the superuser. See appropriate
privileges.
process
An invocation of a program, or the execution of an image (see image). Although all commands and utili-
ties are executed within processes, not all commands or utilities have a one-to-one correspondence with
processes. Some commands (such as cd) execute within a process, but do not create any new processes.
Others (such as in the case of
ls|wc-l) create multiple processes. Several processes can be running
the same program, but each can be different data and be in different stages of execution. A process can
also be thought of as an address space and single thread of control that executes within that address
space and its required system resources. A process is created by another process issuing the fork(2)
function. The process that issues fork (2) is known as the parent process and the new process created
by the fork (2) as the child process.
process 1
See
init.
process group
Each process in the system is a member of a process group. This grouping permits the signaling of
related processes. A newly created process joins the process group of its creator.
process group ID
Each process group in the system is uniquely identified during its lifetime by a process group ID,a
positive integer less than or equal to
PIC_MAX.Aprocess group ID cannot be reused by the system
until the process group lifetime ends.
process group leader
A process group leader is a process whose process ID is the same as its process group ID.
process group lifetime
A period of time that begins when a process group is created and ends when the last remaining process
in the group leaves the group, either due to process termination or by calling the setsid (2) or setpgid (2)
functions.
process ID
Each active process in the system is uniquely identified during its lifetime by a positive integer less than
or equal to
PID_MAX called a process ID. A process ID cannot be reused by the system until after the
process lifetime ends. In addition, if there exists a process group whose process group ID is equal to that
process ID, the process ID cannot be reused by the system until the process group lifetime ends.
process lifetime
After a process is created with a fork (2) function, it is considered active. Its thread of control and
address space exist until it terminates. It then enters an inactive state where certain resources may be
HP-UX 11i Version 3: September 2010 17 Hewlett-Packard Company 17