glossary.9 (2010 09)

s
glossary(9) glossary(9)
SCCS are admin (1), cdc (1), delta (1), get(1), prs (1), rmdel (1), sact (1), sccsdiff(1), unget (1), val (1), and
what(1).
SCCS file
An ordinary text file that has been modified so the Source Code Control System (SCCS) can be used
with it. This modification is done automatically by the admin(1) command. See also delta.
secondary prompt
One or more characters that the shell prints on the display, indicating that more input is needed. This
prompt is not encountered nearly as frequently as the shell’s primary prompt (see prompt). When it
occurs, it is usually caused by an omitted right quote on a string (which confuses the shell), or when you
enter a shell programming language control-flow construct (such as a
for construct) from the command
line. By default, the shell’s secondary prompt is the greater-than sign (
>), but you can re-define it by set-
ting the shell variable
PS2 appropriately in your
.profile file. (The C shell has no secondary prompt.)
semaphore identifier (semid)
A unique positive integer created by a semget (2) system call. Each semid has a set of semaphores and a
data structure associated with it. The data structure is referred to as
semid_ds and contains the follow-
ing members:
struct
ipc_perm sem_perm; /* operation permission */
ushort sem_nsems; /* number of sems in set */
time_t sem_otime; /* last operation time */
time_t sem_ctime; /* last change time */
/* Times measured in secs since */
/* 00:00:00 GMT, Jan. 1, 1970 */
Semaphore identifiers can be created using ftok (3C).
sem_perm is a ipc_perm structure that specifies the semaphore operation permission (see below). This
structure includes the following members:
uid_t cuid; /* creator user id */
gid_t cgid; /* creator group id */
uid_t uid; /* user id */
gid_t gid; /* group id */
mode_t mode; /* r/a permission */
The value of sem_nsems is equal to the number of semaphores in the set. Each semaphore in the set is
referenced by a positive integer referred to as a sem_num. sem_num values run sequentially from 0 to
the value of sem_nsems minus 1. sem_otime is the time of the last semop (2) operation, and
sem_ctime is the time of the last semctl (2) operation that changed a member of the above structure.
semaphore operation permissions
In the semop(2) and semctl (2) system call descriptions, the permission required for an operation is indi-
cated for each operation. Whether a particular process has these permissions for an object is determined
by the object’s permission mode bits as follows:
00400 Read by user
00200 Alter by user
00060 Read, Alter by group
00006 Read, Alter by others
Read and Alter permissions on a
semid are granted to a process if one or more of the following are true:
The process’s effective user ID is superuser.
The process’s effective user ID matches
sem_perm.[c]uid in the data structure associated with
semid and the appropriate bit of the "user" portion (0600) of sem_perm.mode is set.
The process’s effective user ID does not match
sem_perm.[c]uid and the appropriate bit of the
"group" portion (060) of sem_perm.mode is set.
The process’s effective user ID does not match
sem_perm.[c]uid and the process’s effective group
ID does not match sem_perm.[c]gid and neither of sem_perm.[c]gid is in the process’s group
access list and the appropriate bit of the "other" portion (06) of sem_perm.mode is set.
20 Hewlett-Packard Company 20 HP-UX 11i Version 3: September 2010