glossary.9 (2010 09)

s
glossary(9) glossary(9)
Otherwise, the corresponding permissions are denied.
semid
See semaphore identifier.
session
Each process group is a member of a session. A process is considered to be a member of the session of
which its process group is a member. A newly created process joins the session of its creator. A process
can alter its session membership (see setsid (2)). A session can have multiple process groups (see
setpgid (2)).
session leader
A process that has created a session (see setsid (2)).
session lifetime
The period between when a session is created and the end of the lifetime of all process groups that
remain as members of the session.
set-group-ID bit
A single bit in the mode of every file in the file system. If a file is executed whose set-group-ID bit is
set, the effective group ID of the process which executed the file is set equal to the real group ID of
the owner of the file. See also group.
set-user-ID bit
A single bit in the mode of every file in the file system. If a file is executed whose set-user-ID bit is set,
the effective user ID of the process that executed the file is set equal to the real user ID of the owner
of the file.
shared library
An executable file that can be shared between several different programs. Code from a shared library is
not linked into the program by ld(1), but is instead mapped into the process’s address space at run time
by the dynamic loader. Shared libraries must contain position-independent code, and are created by
ld(1). They typically have the file name suffix
.sl.
shared memory identifier (shmid)
A unique positive integer created by a shmget(2) system call. Each shmid has a segment of memory
(referred to as a shared memory segment) and a data structure associated with it. The data structure is
referred to as
shmid_ds and contains the following members:
struct
ipc_perm shm_perm; /* operation permission struct */
size_t shm_segsz; /* size of segment */
pid_t shm_cpid; /* creator pid */
pid_t shm_lpid; /* pid of last operation */
shmatt_t shm_nattch; /* number of current attaches */
time_t shm_atime; /* last attach time */
time_t shm_dtime; /* last detach time */
time_t shm_ctime; /* last change time */
/* Times measured in secs since */
/* 00:00:00 GMT, Jan. 1, 1970 */
Shared memory identifiers can be created using ftok (3C).
shm_perm is a ipc_perm structure that specifies the permission for a shmop(2) or shmctl (2) operation
(see below). This structure includes the following members:
uid_t cuid; /* creator user id */
gid_t cgid; /* creator group id */
uid_t uid; /* user id */
gid_t gid; /* group id */
mode_t mode; /* r/w permission */
shm_segsz specifies the size of the shared memory segment. shm_cpid is the process id of the process
that created the shared memory identifier. shm_lpid is the process id of the last process that per-
formed a shmop (2) operation. shm_nattch is the number of processes that currently have this segment
HP-UX 11i Version 3: September 2010 21 Hewlett-Packard Company 21