glossary.9 (2010 09)

s
glossary(9) glossary(9)
solidus
See slash.
source code
The fundamental high-level information (program) written in the syntax of a specified computer
language. Object (machine-language) code is derived from source code. When dealing with an HP-UX
shell command language, source code is input to the command language interpreter. The term shell
script is synonymous with this meaning. When dealing with the C Language, source code is input to
the cc(1) command. Source code can also refer to a collection of sources meeting any of the above condi-
tions.
special le
A file associated with an I/O device. Often called a device file. Special files are read and written the
same as ordinary files, but requests to read or write result in activation of the associated device. Due to
convention and consistency, these files should always reside in the
/dev directory. See also file.
special system processes
Special system processes are those which are critical to basic system operation. They include: the
scheduler, the initialization process (also known as init) and the pager.
SS/80
See CS/80.
standard error
The destination of error and special messages from a program, intended to be used for diagnostic mes-
sages. The standard error output is often called stderr, and is automatically opened for writing on file
descriptor 2 for every command invoked. By default, the user’s terminal is the destination of all data
written to standard error, but it can be redirected elsewhere. Unlike standard input and standard out-
put, which are never used for data transfer in the "wrong" direction, standard error is occasionally read.
This is not recommended practice, since I/O redirection is likely to break a program doing this.
standard input
The source of input data for a program. The standard input file is often called stdin, and is automati-
cally opened for reading on file descriptor 0 for every command invoked. By default, the user’s terminal
is the source of all data read from standard input, but it can be redirected from another source.
standard output
The destination of output data from a program. The standard output file is often called stdout, and is
automatically opened for writing on file descriptor 1 for every command invoked. By default, the user’s
terminal is the destination of all data written to standard output, but it can be redirected elsewhere.
stderr
See standard error.
stdin
See standard input.
stdout
See standard output.
stream
A term most often used in conjunction with the standard I/O library routines documented in Section 3 of
this manual. A stream is simply a file pointer (declared as
FILE *stream) returned by the fopen (3S)
library routines. It may or may not have buffering associated with it (by default, buffering is assigned,
but this can be modified with setbuf (3S)).
sticky bit
A single bit in the mode of every file in the file system. The sticky bit has no significance if it is set on a
regular file.
If set on a directory, the files in that directory can be removed or renamed only by the owner of the file,
the owner of the directory containing the file, or superuser. See also chmod(2), rename(2), rmdir(2), and
unlink (2).
HP-UX 11i Version 3: September 2010 23 Hewlett-Packard Company 23