glossary.9 (2010 09)

f
glossary(9) glossary(9)
A file descriptor is obtained through system calls such as creat (2), fcntl (2), open (2), pipe (2), or dup(2).
The le descriptor is used as an argument by calls such as read (2), write (2), ioctl (2), and close (2).
The value of a file descriptor has a range from 0 to one less than the system-defined maximum. The
system-defined maximum is the value
NOFILE
in <sys/param.h>.
file group class
A process is in the file group class of a file if the process is not the file owner class and if the
effective group ID or one of the supplementary group IDs of the process matches the group ID asso-
ciated with the file.
file hierarchy
The collection of one or more file systems available on a system. All les in these file systems are
organized in a single hierarchical structure in which all of the nonterminal nodes are directories.
Because multiple links can refer to the same file, the directory is properly described as a directed graph.
file name
A string of up to 14 bytes (or 255 bytes on file systems that support long file names) used to refer to an
ordinary file, special file, or directory. The byte values NUL (null) and slash (
/) cannot be used as char-
acters in a file name. Note that it is generally unwise to use
*, ?, ,, [,or]
as part of file names because
the shell attaches special meaning to these characters (see sh(1), csh (1), or ksh (1)). Avoid beginning a
file name with
-, +,or=, because to some programs, these characters signify that a command argument
follows. A file name is sometimes called a path name component. Although permitted, it is inadvisable to
use characters that do not have a printable graphic on the hardware you commonly use, or that are likely
to confuse your terminal.
file name portability
File names should be constructed from the portable file name character set because the use of other
characters can be confusing or ambiguous in certain contexts.
file offset
The file offset specifies the position in the file where the next I/O operation begins. Each open le
description associated with either a regular file or special file has a file offset. There is no file offset
specified for a pipe or FIFO.
file other class
A process is in the file other class if the process is not in the file owner class or file group class.
file owner class
A process is in the file owner class if the effective user ID of the process matches the user ID of the
file.
file permission bits
See permission bits.
file pointer
A data element obtained through any of the fopen (3S) standard I/O library routines that "points to"
(refers to) a file opened for reading and/or writing, and which keeps track of where the next I/O operation
will take place in the file (in the form of a byte offset relative to the beginning of the file). After obtaining
the file pointer, it must thereafter be used to refer to the open file when using any of the standard I/O
library routines. (See stdio (3S) for a list of these routines.)
file serial number
A file-system-unique identifier for a given file, also known as the file’s inode number. Each file serial
number identifies exactly one inode. File serial numbers are not necessarily unique across file sys-
tems in the file hierarchy.
file status flags
Part of an open file description. These flags can be used to modify the behavior of system calls that
access the file described by the open file description.
8 Hewlett-Packard Company 8 HP-UX 11i Version 3: September 2010