hilkbd.7 (2010 09)

h
hilkbd(7) hilkbd(7)
keyboard identification field within the configuration code.
KBD_STATUS Read the keyboard status register.
This request returns a one-byte value containing bit flags specifying the state of the shift
and control keys in the
char variable to which arg points:
KBD_STAT_LEFTSHIFT The left shift key is up
KBD_STAT_RIGHTSHIFT The right shift key is up
KBD_STAT_SHIFT Both shift keys are up
KBD_STAT_CTRL The control key is up
Other bits are undefined.
KBD_REPEAT_RATE
Set the keyboard auto-repeat rate.
The one-byte value to which arg points is the negative of the repeat period, in tens of mil-
liseconds. The repeat rate is the reciprocal of the repeat period. A parameter of zero dis-
ables auto-repeat.
KBD_REPEAT_DELAY
Set the keyboard auto-repeat delay.
The one-byte value to which arg points is the negative of the repeat delay, in tens of mil-
liseconds.
KBD_BEEP Cause an audible beep.
The one-byte value to which arg points specifies the volume of the beep, within the range
0 through KBD_MAXVOLUME. Implementations with fewer than
KBD_MAXVOLUME
discrete levels of volume will scale the parameter into the smaller range.
ERRORS
[EINVAL] An invalid parameter was detected by
ioctl().
[EINTR] A signal was caught during a
read() system call.
[ENXIO] No keyboard is present on the HP-HIL link specified by the minor number.
[ENODEV] An attempt was made to use
write() using hilkbd.
[EBUSY] The device is already open.
AUTHOR
hilkbd was developed by the Hewlett-Packard Company.
FILES
/dev/hilkbd*
SEE ALSO
mknod(1M), select(2), signal(2), hil(7), termio(7).
2 Hewlett-Packard Company 2 HP-UX 11i Version 3: September 2010