mt.7 (2010 09)

m
mt(7) mt(7)
(((dev) & (˜MT_INDEX_MASK)) | \
(index << MT_INDEX_BIT_POS) | \
MT_USER_CONFIG_MASK) : \
((mt_check_newdev_options(dev, D_CHR, ˜MT_INDEX_MASK)) | \
(index << MT_INDEX_BIT_POS)))
#define M_DFLT_DENSITY_PUT_AGILE(dev,density) \
((io_is_legacy_dev(dev, D_CHR) == MT_IS_LEGACY_DEV) ? \
(((dev) & (˜MT_DENSITY_MASK)) | \
(density << MT_DENSITY_BIT_POS)) : \
((mt_check_newdev_options(dev, D_CHR, ˜MT_DENSITY_MASK)) | \
(density << MT_DENSITY_BIT_POS)))
#define M_TRANSPARENT_MODE_AGILE(dev) \
((io_is_legacy_dev(dev, D_CHR) == MT_IS_LEGACY_DEV) ? \
(((dev) & MT_TRANSPARENT_MASK) == \
MT_TRANSPARENT_VAL) : \
((mt_check_newdev_options(dev, D_CHR, MT_TRANSPARENT_MASK)) \
== MT_TRANSPARENT_VAL))
The following is included from
<sys/mtio.h> and describes the possible tape operations:
/* mag tape I/O control requests */
#define MTIOCTOP _IOW(’m’, 1, struct mtop) /* do mag tape op */
#define MTIOCGET _IOR(’m’, 2, struct mtget) /* get tape status */
/* structure for MTIOCTOP - mag tape op command */
struct mtop {
short mt_op; /* operations defined below */
int32_t mt_count; /* how many of them */
};
/* operations */
#define MTWEOF 0 /* write filemark (end-of-file record) */
#define MTFSF 1 /* forward space file */
#define MTBSF 2 /* backward space file */
#define MTFSR 3 /* forward space record */
#define MTBSR 4 /* backward space record */
#define MTREW 5 /* rewind */
#define MTOFFL 6 /* rewind and put the drive offline (may eject) */
#define MTNOP 7 /* no operation, may set status */
#define MTEOD 8 /* DDS, QIC and 8MM only - seek to end-of-data */
#define MTWSS 9 /* DDS and 8MM only - write setmark(s) */
#define MTFSS 10 /* DDS and 8MM only - space forward setmark(s) */
#define MTBSS 11 /* DDS and 8MM only - space backward setmark(s) */
#define MTSTARTVOL 12 /* Start a new volume (for ATS) */
#define MTENDVOL 13 /* Terminate a volume (for ATS) */
#define MTRES 14 /* Reserve Device */
#define MTREL 15 /* Release Device */
#define MTERASE 16 /* Erase media */
/* structure for MTIOCGET - mag tape get status command */
struct mtget {
long mt_type; /* type of magtape device */
long mt_resid; /* residual count */
/* The following two registers are device dependent */
6 Hewlett-Packard Company 6 HP-UX 11i Version 3: September 2010