mt.7 (2010 09)

m
mt(7) mt(7)
GMT_D_DDS1(x) Returns TRUE if the density encoded in
mt_gstat is DDS1
(with or without compression).
GMT_D_DDS1c(x) Returns TRUE if the density encoded in
mt_gstat is DDS1
plus compression.
GMT_D_DDS2(x) Returns TRUE if the density encoded in
mt_gstat is DDS2
(with or without compression).
GMT_D_DDS2c(x) Returns TRUE if the density encoded in
mt_gstat is DDS2
plus compression.
GMT_D_DLT_42500_24(
x) Returns TRUE if the density encoded in
mt_gstat is 42500
bpi, 24 track pairs.
GMT_D_DLT_42500_56(
x) Returns TRUE if the density encoded in
mt_gstat is 42500
bpi, 56 track pairs.
GMT_D_DLT_62500_64(
x) Returns TRUE if the density encoded in
mt_gstat is 62500
bpi (with or without compression).
GMT_D_DLT_62500_64c(
x) Returns TRUE if the density encoded in
mt_gstat is 62500
bpi plus compression.
GMT_D_DLT_81633_64(
x) Returns TRUE if the density encoded in mt_gstat is 81633
bpi (with or without compression).
GMT_D_DLT_81633_64c(
x) Returns TRUE if the density encoded in mt_gstat is 81633
bpi plus compression.
GMT_D_DLT_85937_52(
x) Returns TRUE if the density encoded in mt_gstat is 85937
bpi (with or without compression).
GMT_D_DLT_85937_52c(
x) Returns TRUE if the density encoded in mt_gstat is 85937
bpi plus compression.
GMT_D_3480(x) Returns TRUE if the density encoded in mt_gstat is for a
3480 device (with or without compression).
GMT_D_3480c(x) Returns TRUE if the density encoded in mt_gstat is for a
3480 device with compression.
GMT_DR_OPEN(x) Does not apply to any currently supported devices. Always
returns FALSE.
HP-UX silently enforces a tape record blocking factor (
MAXPHYS) on large I/O requests. For example, a
user write request with a length of ten times MAXPHYS will actually reach the media as ten separate
records. A subsequent read (with ten times MAXPHYS as a length) will look like a single operation to the
user, even though HP-UX has broken it up into ten separate read requests to the driver. The blocking
function is transparent to the user during writes. It is also transparent during reads unless:
The user picks an arbitrary read length greater than
MAXPHYS.
The user attempts to read a third-party tape containing records larger than
MAXPHYS.
Since the value for
MAXPHYS is relatively large (usually >= 256K bytes), this is typically not a problem.
The
MTNOP operation does not set the device-independent status word.
EXAMPLES
Assuming that fd is a valid file descriptor, the following example writes two consecutive filemarks on the
tape:
#include <sys/types.h>
#include <sys/mtio.h>
struct mtop mtop;
mtop.mt_op = MTWEOF;
mtop.mt_count = 2;
ioctl(fd, MTIOCTOP, &mtop);
If fd is a valid file descriptor for an open DDS drive, the following example spaces forward to just past the
next setmark:
8 Hewlett-Packard Company 8 HP-UX 11i Version 3: September 2010