profile.4 (2010 09)

p
prole(4) prole(4)
NAME
profile - set up user’s environment at login time
DESCRIPTION
If the file
/etc/profile exists, it is executed by the shell for every user who logs in. The file
/etc/profile should be set up to do only those things that are desirable for every user on the system,
or to set reasonable defaults. If a user’s login (home) directory contains a file named
.profile, that file
is executed (via the shell’s
exec .profile) before the session begins. .profile files are useful for
setting various environment parameters, setting terminal modes, or overriding some or all of the results
of executing
/etc/profile.
EXAMPLES
The following example is typical (except for the comments):
# Make some environment variables global
export MAIL PATH TERM
# Set file creation mask
umask 22
# Tell me when new mail comes in
MAIL=/var/mail/myname
# Add my /bin directory to the shell search sequence
PATH=$PATH:$HOME/bin
# Set terminal type
echo "terminal: \c"
read TERM
case $TERM in
300) stty cr2 nl0 tabs; tabs;;
300s) stty cr2 nl0 tabs; tabs;;
450) stty cr2 nl0 tabs; tabs;;
hp) stty cr0 nl0 tabs; tabs;;
745|735) stty cr1 nl] -tabs; TERM=745;;
43) stty cr1 nl0 -tabs;;
*) echo "$TERM unknown";;
esac
A more complete model .profile can be found in /etc/skel/.profile
.
FILES
$HOME/.profile
/etc/profile
SEE ALSO
env(1), login(1), mail(1), sh(1), stty(1), su(1), environ(5), term(5).
HP-UX 11i Version 3: September 2010 1 Hewlett-Packard Company 1

Summary of content (2 pages)