sd.5 (2011 03)

s
sd(5) sd(5)
Operands
Most SD commands support two types of operands: software selections followed by target selections .
These operands are separated by the "at" (
@) character. This syntax implies that the command operates
on "selections at targets".
Software Selections
The selections operands consist of software_selections for most SD commands. For the
swjob and
swreg commands, the selections can be job_ids and roots_or_depots respectively.
The SD commands support the following syntax for each software_selection:
bundle
[.product[.subproduct][.
fileset]][,version]
product[.subproduct][.fileset
][,version]
You can specify selections with the following shell wildcard and pattern-matching notations:
[], *, ?
For example, the following expression installs all bundles and products with tags that end with
"man":
swinstall -s sw_server *man
Bundles and subproducts are recursive. Bundles can contain other bundles and subproducts can
contain other subproducts . For example:
swinstall bun1.bun2.prod.sub1.sub2.fset,r=1.0
or (using expressions):
swinstall bun[12].bun?.prod.sub*,a=HP-UX
The \* software specification selects all products. Use this specification with caution.
The
version component has the form:
[,r <op> revision][,a <op> arch][,v <op> vendor]
[,c <op> category][,q=qualifier][,l=location]
[,fr <op> revision][,fa <op> arch]
location applies only to installed software and refers to software installed to a location other
than the default product directory.
fr and fa apply only to filesets.
r , a , v , c , and l apply only to bundles and products. They are applied to the leftmost bun-
dle or product in a software specification.
The <op> (relational operator) component can be of the form:
=, ==, >=, <=, <, >,or!=
which performs individual comparisons on dot-separated fields.
For example,
r>=B.11.00 chooses all revisions greater than or equal to B.11.00. The sys-
tem compares each dot-separated field to find matches. Shell patterns are not allowed with these
operators.
The
= (equals) relational operator lets you specify selections with the following shell wildcard
and pattern-matching notations:
[], *, ?, !
For example, the expression r=1[01].* returns any revision in version 10 or version 11.
All version components are repeatable within a single specification (for example,
r>=A.12,
r<A.20). If multiple components are used, the selection must match all components.
Fully qualified software specs include the r=, a=, and v= version components even
if they contain empty strings. For installed software, l= is also included.
No space or tab characters are allowed in a software selection.
The software instance_id can take the place of the version component. It has the form:
[instance_id]
HP-UX 11i Version 3: March 2011 7 Hewlett-Packard Company 7