sttyV6.7 (2010 09)

s
sttyv6(7) sttyv6(7)
NAME
sttyv6: stty - terminal interface for Version 6/PWB compatibility
DESCRIPTION
These routines attempt to map the UNIX Time-Sharing System, Sixth Edition (Version 6), and PWB stty
and gtty calls into the current ioctls that perform the same functions. The mapping cannot be perfect.
The way the features are translated is described below. The reader should be familiar with
termio
before studying this entry.
The following data structure is defined in the include file
<sgtty.h>:
struct sgttyb {
char sg_ispeed; /* input speed */
char sg_ospeed; /* output speed */
char sg_erase; /* erase character */
char sg_kill; /* kill character */
int sg_flags; /* mode flags */
}
The flags, as defined in sgtty.h, are:
define HUPCL
define XTABS
define LCASE
define ECHO
define CRMOD
define RAW
define ODDP
define EVENP
define ANYP
define NLDELAY
define TBDELAY
define CRDELAY
define VTDELAY
define BSDELAY
define CR0
define CR1
define CR2
define CR3
define NL0
define NL1
define NL2
define NL3
define TAB0
define TAB1
define NOAL
define FF0
define FF1
define BS0
define BS1
When the
stty command (ioctl TIOCSETP) is executed, the flags in the old sgttyb structure are
mapped into their new equivalents in the termio structure. Then the TCSETA command is executed.
The following table shows the mapping between the old
sgttyb flags and the current termio flags.
Note that flags contained in the termio structure that are not mentioned below are cleared.
HUPCL (if set) sets the termio HUPCL flag;
HUPCL (if clear) clears the termio HUPCL flag;
XTABS (if set) sets the termio TAB3 flag;
XTABS (if clear) clears the termio TAB3 flag;
TBDELAY (if set) sets the termio TAB1 flag;
TBDELAY (if clear) clears the termio TAB1 flag;
LCASE (if set) sets the termio IUCLC, OLCUC, and XCASE flags;
HP-UX 11i Version 3: September 2010 1 Hewlett-Packard Company 1

Summary of content (4 pages)