sttyV6.7 (2010 09)

s
sttyv6(7) sttyv6(7)
LCASE (if clear) clears the termio IUCLC, OLCUC, and XCASE flags;
ECHO (if set) sets the termio ECHO flag;
ECHO (if clear) clears the termio ECHO flag;
NOAL (if set) sets the termio ECHOK flag;
NOAL (if clear) clears the termio ECHOK flag;
CRMOD (if set) sets the termio ICRNL and ONLCR
flags; also, if CR1 is set, the termio CR1 flag is set, and if CR2 is set, the termio ONOCR and CR2
flags are set;
CRMOD (if clear)
sets the termio ONLRET flag; also, if NL1 is set, the termio CR1 flag is set, and if NL2 is set, the
termio CR2 flag is set;
RAW (if set) sets the termio
CS8 flag, and clears the termio ICRNL and IUCLC flags; also, default values of 6 characters and
0.1 seconds are assigned to MIN and TIME, respectively;
RAW (if clear) sets the termio
BRKINT, IGNPAR, ISTRIP, IXON, IXANY, OPOST, CS7, PARENB, ICANON, and ISIG flags; also,
the default values control-D and null are assigned to the control characters EOF and EOL, respec-
tively;
ODDP (if set) if EVENP is also set, clears the termio
INPCK flag; otherwise, sets the termio PARODD flag;
VTDELAY (if set) sets the termio FFDLY flag;
VTDELAY (if clear) clears the termio FFDLY flag;
BSDELAY (if set) sets the termio BSDLY flag;
BSDELAY (if clear) clears the termio BSDLY flag.
In addition, the
termio CREAD bit is set, and, if the baud rate is 110, the CSTOPB bit is set.
When using
TIOCSETP, the ispeed entry in the sgttyb structure is mapped into the appropriate speed
in the termio CBAUD field. The erase and kill sgttyb entries are mapped into the termio
erase and
kill characters.
When the
gtty (ioctl TIOCGETP) command is executed, the termio TCGETA command is first exe-
cuted. The resulting termio structure is then mapped into the sgttyb structure, which is then
returned to the user.
The following table shows how the
termio flags are mapped into the old sgttyb structure. Note that
all flags contained in the sgttyb structure that are not mentioned below are cleared.
HUPCL (if set) sets the sgttyb HUPCL flag;
HUPCL (if clear) clears the sgttyb HUPCL flag;
ICANON (if set) sets the sgttyb RAW flag;
ICANON (if clear) clears the sgttyb RAW flag;
XCASE (if set) sets the sgttyb LCASE flag;
XCASE (if clear) clears the sgttyb LCASE flag;
ECHO (if set) sets the sgttyb ECHO flag;
ECHO (if clear) clears the sgttyb ECHO flag;
ECHOK (if set) sets the sgttyb NOAL flag;
ECHOK (if clear) clears the sgttyb NOAL flag;
PARODD (if set) sets the sgttyb ODDP flag;
PARODD (if clear) clears the sgttyb ODDP flag;
INPCK (if set) sets the sgttyb EVENP flag;
PARODD, INPCK (if both clear) sets the sgttyb
ODDP and EVENP flags;
ONLCR (if set) sets the sgttyb
CRMOD flag; also, if CR1 is set, the sgttyb CR1 flag is set, and if CR2 is set, the sgttyb CR2 flag is
set;
ONLCR (if clear) if CR1 is set, the sgttyb
NL1 flag is set, and if CR2 is set, the sgttyb NL2 flag is set;
TAB3 (if set) sets the sgttyb XTABS flag;
TAB3 (if clear) clears the sgttyb XTABS flag;
TAB1 (if set) sets the sgttyb TBDELAY flag;
TAB1 (if clear) clears the sgttyb TBDELAY flag;
FFDLY (if set) sets the sgttyb VTDELAY flag;
FFDLY (if clear) clears the sgttyb VTDELAY flag;
2 Hewlett-Packard Company 2 HP-UX 11i Version 3: September 2010