unistd.5 (2010 09)

u
unistd(5) unistd(5)
NAME
unistd: unistd.h - standard structures and symbolic constants
SYNOPSIS
#include <unistd.h>
DESCRIPTION
The header <unistd.h> defines the following structures and symbolic constants:
Symbolic constants for the
access() function:
R_OK Test for read permission.
W_OK Test for write permission.
X_OK Test for execute (search) permission.
F_OK Test for existence of file.
The constants
F_OK, R_OK, W_OK
, and X_OK and the expressions R_OK|W_OK, R_OK|X_OK, and
R_OK|W_OK|X_OK
all have distinct values.
Symbolic constant representing a null pointer:
NULL
Symbolic constants for the lseek() and fcntl() functions (the following constants have distinct
values):
SEEK_SET Set file offset to "offset".
SEEK_CUR Set file offset to current plus "offset".
SEEK_END Set file offset to EOF plus "offset".
Symbolic constants (with fixed values):
_POSIX_VERSION Integer value indicating version of IEEE Std 1003.1 standard imple-
mented. The current value is 199009L, indicating the (4-digit) year and
(2-digit) month that the standard was approved by the IEEE Standards
Board. However, if any of the symbols
_AES_SOURCE, _XPG3,or
_POSIX1_1988 is defined before <unistd.h> is included, the value
of this symbol will be 198808L.
_POSIX2_VERSION Integer value indicating version of IEEE Std 1003.2 standard imple-
mented. The current value is 199209L, indicating the (4-digit) year and
(2-digit) month that the standard was approved by the IEEE Standards
Board.
_POSIX2_C_VERSION
Integer value indicating version of IEEE Std 1003.2 C-Language Binding
Option implemented. The current value is 199209L, indicating the (4-
digit) year and (2-digit) month that the standard was approved by the
IEEE Standards Board.
_XOPEN_VERSION Integer value indicating issue number of the X/Open Portability Guide
implemented. The current value is 4, indicating Issue 4. However, if the
symbol
_XPG3 is defined before <unistd.h> is included, the value of
this symbol will be 3.
The following symbolic constants are defined in this header if the state of the corresponding option or res-
triction does not vary after compilation. If a symbol is absent from this header, the value or presence of
the corresponding option or restriction should be determined at execution time through
sysconf() or
pathconf():
_POSIX_CHOWN_RESTRICTED
The use of chown() is restricted to processes that have appropriate
privileges.
_POSIX_JOB_CONTROL Implementation supports job control (true of all HP-UX implementa-
tions).
_POSIX_NO_TRUNC Pathname components longer than NAME_MAX generate an error.
_POSIX_REALTIME_SIGNALS
Implementation supports Realtime Signals Extensions (true of all HP-UX
implementations).
HP-UX 11i Version 3: September 2010 1 Hewlett-Packard Company 1

Summary of content (4 pages)