vparresources.5 (2010 09)

v
vparresources(5) vparresources(5)
or
mem::size[:base|floating]
specifications.
However there is no such restriction if the target vPar is Up. Adding/deleting a range to/from an
Up vPar increases/decreases the total memory assigned to that vPar.
When you specify an explicit range of memory (whether adding or deleting), to a Down vPar, you
do not change the total amount of memory assigned to the vPar. When adding, you merely specify
that the particular range you specify be one part of the total amount of that memory type (CLM or
ILM) assigned to your vPar. When deleting, the specific range is returned to the pool of total CLM
or ILM memory assigned to the vPar.
Hewlett-Packard recommends that users configure specific memory ranges only when required for
performance reasons. In other situations, specify only total memory and allow the monitor to
manage the actual ranges allocated.
Command Examples
If more than one task is specified in a command, they are processed in the order (left-to-right) in which
they are encountered on the command line. Some tasks will affect the outcome of others. Here is an
example of correct usage, as well as counterexamples within the description.
vparcreate -p my_vp -a cpu::2 -a cpu:::2:4 -a cpu:0/13 -a cpu:0/14 \
-a mem::1280 -a mem:::0x40000000:128 -a io:0/0/8 -a io:0/1/10 \
-a 0/0/8/0/0.5.0:boot
At creation time, before any options are processed, min is equal to 1,asisnum. Assume that the default
max is sufficiently high, and that the specified resources are available for allocation.
-a cpu::2 succeeds because num(2) is within the range of the min and the max.
-a cpu:::2:4 then succeeds because num(2) is still within the required range. Note that if
the two options were reversed the command would return an error due to left-to-right option pro-
cessing, and the desired min would exceed the default num.
Finally, the specification of the two CPUs at explicit paths
0/13 and 0/14 succeeds because we
have previously assigned two non-cell-specific CPUs for them to replace. Note that without the
first two -a options, the -a cpu:0/14 option would fail, because there would only be room for
one user-assigned CPU.
The allocation of 128 MB of specific memory at address
0x40000000 succeeds only because the
total allocated memory was first set to 1280 MB. The 128 MB is taken from that 1280 MB; no
new memory is added as a result of the -a mem:::0x40000000:128
option.
The following
vparmodify command adds two non-CLP CPUs to a vPar that has the Static attribute
set. The Static attribute is then restored.
vparmodify -p my_vp -S dynamic -a cpu::2 -S static
HP-UX 11i Version 3: September 2010 15 Hewlett-Packard Company 15