vparresources.5 (2010 09)

v
vparresources(5) vparresources(5)
allocation of that type of memory to the vPar, the warning is suppressed. Instead you will see the
relevant error message. NOTE: Assignment of ranges that are not granule aligned is not supported.
Hence this is not recommended.
Here are some examples of memory range specifications. For simplicity, all examples show memory
range addition, but operation is similar when deleting memory ranges. Also note that when no base or
floating attribute is specified, the add is treated as base memory add. Suppose that the ILM granularity is
128 MB, you have configured 1GB of ILM as base and 1GB of ILM as floating in your vPar and the follow-
ing ILM ranges are available:
[Available ILM (Base /Range)]: 0x4080000000/128
(bytes) (MB) 0x40C0000000/1536
Each of the following examples starts from this initial condition.
vparmodify -p my_vp -a mem:::0x4080000000:128:base
You have specified the entire granule aligned range to be added as base memory, and the request
does not exceed your total ILM configuration. The request is granted. No message is displayed.
vparmodify -p my_vp -a mem:::0x4080000000:128:floating
You have specified the entire granule aligned range to be added as floating memory, and the request
does not exceed your total floating ILM configuration. The request is granted. No message is
displayed.
vparmodify -p my_vp -a mem:::0x40800a0000:20:base
The "0x40800a0000" is adjusted downward to the start of the available range and the "20" is
adjusted upward to the next granule boundary which is within the end of the available range. The
result is the same as in the first example. The request is granted, but the command displays a
warning of the modification.
vparmodify -p my_vp -a mem:::0x4080000000:256
You have specified a range exceeding that which is available. The request is denied and the com-
mand displays an error.
vparmodify -p my_vp -a mem:::0x40C0000000:128
You have specified one granule starting on a granule boundary. The request is granted. This range
gets added as a base range.
vparmodify -p my_vp -a mem:::0x40C2000000:80
The base is adjusted downward to 0x40C0000000 and the range is adjusted upward to 128, the
granule boundary. The request is granted and the command displays a warning.
vparmodify -p my_vp -a mem:::0x40C2000000:128
Here, the request straddles a granule boundary. The base is adjusted downward to 0x40C0000000
as in the previous example. The original endpoint is adjusted upward to the next granule boun-
dary. The resulting 256 MB request does not exceed your total base ILM configuration. The request
is granted and the command displays a warning.
vparmodify -p my_vp -a mem:::0x40C0000000:1024
You have specified a memory range for your entire base ILM allocation. The request is granted.
vparmodify -p my_vp -a mem:::0x40C0000000:1000
The range is adjusted upward to 1024. The request is granted and the command displays a warn-
ing.
vparmodify -p my_vp -a mem:::0x40C2000000:1024
Again the request straddles a granule boundary. The base is adjusted downward and the original
endpoint is adjusted upward, as in a previous example. This makes the adjusted request equivalent
to 0x40C0000000:1152. Although this is still within the range of available memory, the request
exceeds your total base ILM configuration. The request is denied and the command displays an
error, not a warning.
Changes to memory range specifications can be made when a vPar is
Up,orDown, or when it is in an
alternate database. If changes are made when the vPar is Up and if the b[ase]|f[loat[ing]] attri-
bute is not specified, the memory is added as base memory. Base memory range cannot be deleted when
HP-UX 11i Version 3: September 2010 9 Hewlett-Packard Company 9