HP-UX Reference (11i v1 05/09) - 5 Miscellaneous Topics (vol 9)

s
signal(5) signal(5)
NAME
signal: signal.h - description of signals
SYNOPSIS
#include <signal.h>
DESCRIPTION
The <signal.h> header defines the following symbolic constants, each of which expands to a distinct
constant expression of the type:
void (*)(int)
whose value matches no declarable function.
SIG_DFL Request for default signal handling.
SIG_ERR Return value from signal() in case of error.
SIG_HOLD Request that signal be held.
SIG_IGN Request that signal be ignored.
The following data types are defined through typedef:
sig_atomic_t Integral type of an object that can be accessed as an atomic entity, even in the pres-
ence of asynchronous interrupts
sigset_t Integral or structure type of an object used to represent sets of signals.
pid_t As described in <sys/types.h>
.
This header also declares the constants that are used to refer to the signals that occur in the system. Sig-
nals defined here begin with the letters
SIG. Each of the signals have distinct positive integral values. The
value 0 is reserved for use as the null signal (see kill(2)). Additional implementation-dependent signals
may occur in the system.
The following signals are supported on all implementations (default actions are explained below the table):
Default
Signal Action Description
SIGABRT ii Process abort signal.
SIGALRM i Alarm clock.
SIGFPE ii Erroneous arithmetic operation.
SIGHUP iHangup.
SIGILL ii Illegal instruction.
SIGINT i Terminal interrupt signal.
SIGKILL i Kill (cannot be caught or ignored).
SIGPIPE i Write on a pipe with no one to read it.
SIGQUIT ii Terminal quit signal.
SIGSEGV ii Invalid memory reference.
SIGTERM i Termination signal.
SIGUSR1 i User-defined signal 1.
SIGUSR2 i User-defined signal 2.
SIGCHLD iii Child process terminated or stopped.
SIGCONT v Continue executing, if stopped.
SIGSTOP iv Stop executing (cannot be caught or ignored).
SIGTSTP iv Terminal stop signal.
SIGTTIN iv Background process attempting read.
SIGTTOU iv Background process attempting write.
SIGBUS ii Bus error.
SIGPOLL i Pollable event.
SIGPROF i Profiling timer expired.
SIGSYS ii Bad system call.
SIGTRAP ii Trace/breakpoint trap.
HP-UX 11i Version 1: September 2005 1 Hewlett-Packard Company Section 5343