HP-UX Reference (11i v1 05/09) - 5 Miscellaneous Topics (vol 9)

s
signal(5) signal(5)
SIGURG iii High bandwidth data is available at a socket.
SIGVTALRM i Virtual timer expired.
SIGXCPU ii CPU time limit exceeded.
SIGXFSZ ii File size limit exceeded.
SIGRTMIN i First realtime signal.
SIGRTMAX i Last realtime signal.
The macros SIGRTMIN and SIGRTMAX evaluate to integral expressions, and specify a range that includes
at least {RTSIG_MAX} signal numbers that are reserved for application use and for which the realtime
signal extensions are supported (see sigaction(2)).
The default actions are as follows:
i Abnormal termination of the process. The process is terminated with all the consequences
of _exit() except that the status is made available to
wait() and waitpid() indi-
cates abnormal termination by the specified signal.
ii Abnormal termination of the process. Additionally, implementation-dependent abnormal
termination actions, such as creation of a core file, may occur.
iii Ignore the signal.
iv Stop the process.
v Continue the process, if it is stopped; otherwise ignore the signal.
The header provides a declaration of struct
sigaction, including at least the following members:
what to do on receipt of sig-
nal
void (*sa_handler)(int)
set of signals to be blocked
during execution of the sig-
nal handling function
sigset_t sa_mask
int sa_flags special flags
void (*) sa_sigaction pointer to signal
(int, siginfo_t *, void *) handler function
The storage occupied by sa_handler and sa_sigaction may overlap, and a portable program must not use
both simultaneously.
The following are declared as constants:
SA_NOCLDSTOP Do not generate SIGCHLD when children stop.
SIG_BLOCK The resulting set is the union of the current set and the signal set pointed
to by the argument set.
SIG_UNBLOCK The resulting set is the intersection of the current set and the complement
of the signal set pointed to by the argument set.
SIG_SETMASK The resulting set is the signal set pointed to by the argument set.
SA_ONSTACK Causes signal delivery to occur on an alternate stack.
SA_RESETHAND Causes signal dispositions to be set to SIG_DFL on entry to signal
handlers.
SA_RESTART Causes certain functions to become restartable.
SA_SIGINFO Causes extra information to be passed to signal handlers at the time of
receipt of a signal.
SA_NOCLDWAIT Causes implementations not to create zombie processes on child death.
SA_NODEFER Causes signal not to be automatically blocked on entry to signal handler.
SS_ONSTACK Process is executing on an alternate signal stack.
SS_DISABLE Alternate signal stack is disabled.
Section 5344 Hewlett-Packard Company 2 HP-UX 11i Version 1: September 2005