HP-UX Reference (11i v2 03/08) - 4 File Formats (vol 8)

a
a.out(4) a.out(4)
R_RSEL Use an R-class field selector for the next fixup request instead of the default
appropriate for the instruction. Depending on the current rounding mode, ,
RS´, RD´, or RR´ may be used.
R_N_MODE Select round-down mode (L´/R´). This is the default mode at the beginning of
each subspace. This setting remains in effect until explicitly changed or until
the end of the subspace.
R_S_MODE Select round-to-nearest-page mode (LS´/RS´). This setting remains in effect
until explicitly changed or until the end of the subspace.
R_D_MODE Select round-up mode (LD´/RD´). This setting remains in effect until explicitly
changed or until the end of the subspace.
R_R_MODE Select round-down-with-adjusted-constant mode (LR´/RR´). This setting
remains in effect until explicitly changed or until the end of the subspace.
R_DATA_OVERRIDE
Use the constant V for the next fixup request in place of the constant from the
data word or instruction in the input subspace.
R_TRANSLATED Toggle "translated" mode. This fixup request is generated only by the linker
during a relocatable link to indicate a subspace that was originally read from
an old-format relocatable object file.
R_COMP1 Stack operations. The second byte of this fixup request contains a secondary
opcode. In the descriptions below, A refers to the top of the stack and B refers
to the next item on the stack. All items on the stack are considered signed
32-bit integers.
R_PUSH_PCON1 Push the (positive) constant V.
R_PUSH_DOT Push the current virtual address.
R_MAX Pop A and B, then push max(A, B).
R_MIN Pop A and B, then push min(A, B).
R_ADD Pop A and B, then push A + B.
R_SUB Pop A and B, then push B A.
R_MULT Pop A and B, then push A * B.
R_DIV Pop A and B, then push B / A.
R_MOD Pop A and B, then push B % A.
R_AND Pop A and B, then push A & B.
R_OR Pop A and B, then push A | B.
R_XOR Pop A and B, then push A XOR B.
R_NOT Replace A with its complement.
R_LSHIFT If C = 0, pop A and B, then push B << A. Other-
wise, replace A with A << C.
R_ARITH_RSHIFT If C = 0, pop A and B, then push B >> A. Other-
wise, replace A with A >> C. The shifting is done
with sign extension.
R_LOGIC_RSHIFT If C = 0, pop A and B, then push B >> A. Other-
wise, replace A with A >> C. The shifting is done
with zero fill.
R_PUSH_NCON1 Push the (negative) constant V.
R_COMP2 More stack operations.
R_PUSH_PCON2 Push the (positive) constant V.
R_PUSH_SYM Push the value of the symbol S.
R_PUSH_PLABEL Push the value of a procedure label for symbol S.
The static link bit is L.
R_PUSH_NCON2 Push the (negative) constant V.
R_COMP3 More stack operations.
R_PUSH_PROC Push the value of the procedure entry point S. The
parameter relocation bits are R.
R_PUSH_CONST Push the constant V.
R_PREV_FIXUP The linker keeps a queue of the last four unique multi-byte fixup requests.
This is an abbreviation for a xup request identical to one on the queue. The
queue index X references one of the four; X = 0 refers to the most recent. As a
Section 412 Hewlett-Packard Company 11 HP-UX 11i Version 2: August 2003