Technical data

96 ServerIron ADX NAT64 Configuration Guide
53-1002288-02
Configuring NAT
6
DRAFT: BROCADE CONFIDENTIAL
Dynamic NAT configuration example 1
This section describes the Dynamic NAT configuration shown in Figure 16.
FIGURE 16 Minimum required commands
Figure 16 shows an example of a network using dynamic NAT on a ServerIron ADX ADX. The device
is acting as a gateway to connect a private network to the Internet. The private network, which can
also be considered as the inside network, is using IP addresses in the range of 10.10.1.2 -
10.10.1.254 with a 24-bit subnet mask.
The ServerIron ADX is connected to the Internet through a router. The outside interface of the
ServerIron ADX has a global IP address of 209.157.1.1. The ServerIron ADX also has a pool of
global IP addresses, which are used to map internal IP addresses.
Minimum required commands for dynamic NAT configuration.
1. Identify an internal and external interface on the ServerIron ADX. In this example, Ethernet 1/2
and 1/1 are used.
int eth 1/2
int eth 1/1
2. Assign IP addresses to the interfaces and define the outside and inside boundaries of the NAT
mechanism.
ServerIronADX(config)# int eth 1/2
ServerIronADX(config-if-1/2)# ip address 209.157.1.1/24
ServerIronADX(config-if-1/2)# ip nat outside
ServerIronADX(config-if-1/2)# int eth 1/1
ServerIronADX(config-if-1/1)# ip address 10.10.10.1/24
ServerIronADX(config-if-1/1)# ip nat inside
On Switch (S) code, enable NAT globally.
ServerIronADX(config)# ip nat inside
Remote Server
63.253.63.50
Gateway
VE:63.263.63.244 (Primary)
10.10.1.1 (Secondary)
ServerIron
10.10.1.2
NAT-Pool-IP 63.236.63.200
PC
10.10.1.100
PC
10.10.1.101
Server
10.10.1.102
Server
10.10.1.103
Internet
ip nat inside source list 10 pool out_pool
ip nat pool out_pool 63.236.63.200 63.236.63.200 prex-len 24
!
interface ethernet 2/1
SI
ip address 10.10.1.2 255.255.255.0
ip default-gateway 10.10.1.1
ip nat inside
port-name To-gateway-router
!
interface ethernet 2/9
port-name Inside-Network
!
access-list 10 permit 10.10.1.0 0.0.0.255
!