Administrator Guide

IP Fragments ACL Examples
The following examples show how you can use ACL commands with the fragment keyword to filter fragmented packets.
The following configuration permits all packets (both fragmented and non-fragmented) with destination IP 10.1.1.1. The second
rule does not get hit at all.
Example of Permitting All Packets on an Interface
Dell(conf)#ip access-list extended ABC
Dell(conf-ext-nacl)#permit ip any 10.1.1.1/32Dell(conf-ext-nacl)#deny ip any 10.1.1.1./32
fragments
Dell(conf-ext-nacl)
To deny the second/subsequent fragments, use the same rules in a different order. These ACLs deny all second and subsequent
fragments with destination IP 10.1.1.1 but permit the first fragment and non-fragmented packets with destination IP 10.1.1.1.
Example of Denying Second and Subsequent Fragments
Dell(conf)#ip access-list extended ABC
Dell(conf-ext-nacl)#deny ip any 10.1.1.1/32 fragments
Dell(conf-ext-nacl)#permit ip any 10.1.1.1/32
Dell(conf-ext-nacl)
Layer 4 ACL Rules Examples
The following examples show the ACL commands for Layer 4 packet filtering.
Permit an ACL line with L3 information only, and the fragments keyword is present:
If a packets L3 information matches the L3 information in the ACL line, the packet's FO is checked.
If a packet's FO > 0, the packet is permitted.
If a packet's FO = 0, the next ACL entry is processed.
Deny ACL line with L3 information only, and the fragments keyword is present:
If a packet's L3 information does match the L3 information in the ACL line, the packet's FO is checked.
If a packet's FO > 0, the packet is denied.
If a packet's FO = 0, the next ACL line is processed.
In this first example, TCP packets from host 10.1.1.1 with TCP destination port equal to 24 are permitted. All others are denied.
Example of Permitting All Packets from a Specified Host
Dell(conf)#ip access-list extended ABC
Dell(conf-ext-nacl)#permit tcp host 10.1.1.1 any eq 24
Dell(conf-ext-nacl)#deny ip any any fragment
Dell(conf-ext-nacl)
In the following example, the TCP packets that are first fragments or non-fragmented from host 10.1.1.1 with TCP destination
port equal to 24 are permitted. Additionally, all TCP non-first fragments from host 10.1.1.1 are permitted. All other IP packets
that are non-first fragments are denied.
Example of Permitting Only First Fragments and Non-Fragmented Packets from a Specified Host
Dell(conf)#ip access-list extended ABC
Dell(conf-ext-nacl)#permit tcp host 10.1.1.1 any eq 24
Dell(conf-ext-nacl)#permit tcp host 10.1.1.1 any fragment
Dell(conf-ext-nacl)#deny ip any any fragment
Dell(conf-ext-nacl)
To log all the packets denied and to override the implicit deny rule and the implicit permit rule for TCP/ UDP fragments, use a
configuration similar to the following.
Access Control Lists (ACLs)
113