Administrator Guide

In this scenario, there is an additional 40Gbps link that is sometimes activated between the routers R2 and R5. When LB is configured on
the routers R2 and R3 to communicate with their EBGP peers (routers R4 and R5 respectively), router R2 advertises path X to router R1
with LB indicating that a 10Gbps link is available for communication. Also, the router R3 advertises the path X with LB indicating that a
40Gbps link is available (converted to bytes per second).
If all the required Multipath criteria is satisfied, the router R1 selects both the paths as part of the BGP route selection and installs these
paths in the RIB along with the relative weights of the paths. This mechanism results in load sharing of traffic corresponding to path X
across both the available paths in a 4:1 ratio.
The following example shows the configuration in each router shown in Figure 1:
R1#
interface vlan 10
ip address 1.1.1.1/24
no shut
router bgp 1
maximum-paths ibgp 2
bgp dmzlink-bw
neighbor 1.1.1.2 remote-as 1
neighbor 1.1.1.2 no shutdown
neighbor 1.1.1.3 remote-as 1
neighbor 1.1.1.3 no shutdown
R2#
interface tengigbitethernet 1/1
ip address 1.1.1.2/24
no shut
interface tengigbitethernet 1/2
ip address 4.4.4.1/24
no shut
interface fortyGigE 1/48
ip address 5.5.5.1/24
no shut
router bgp 1
maximum-paths ebgp 2
bgp dmzlink-bw
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 no shutdown
neighbor 4.4.4.2 remote-as 2
neighbor 4.4.4.2 dmzlink-bw
neighbor 4.4.4.2 no shutdown
neighbor 5.5.5.2 remote-as 2
neighbor 5.5.5.2 dmzlink-bw
neighbor 5.5.5.2 no shutdown
R3#
interface tengigbitethernet 1/1
ip address 1.1.1.3/24
no shutdown
interface fortyGigE 1/48
ip address 3.3.3.1/24
no shut
router bgp 1
maximum-paths ebgp 2
bgp dmzlink-bw
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 no shutdown
neighbor 3.3.3.2 remote-as 2
neighbor 3.3.3.2 dmzlink-bw
neighbor 3.3.3.2 no shutdown
R4#
interface tengigbitethernet 1/1
ip address 4.4.4.2/24
no shut
router bgp 2
maximum-paths ebgp 2
bgp dmzlink-bw
neighbor 4.4.4.1 remote-as 1
neighbor 4.4.4.1 dmzlink-bw
neighbor 4.4.4.1 no shutdown
Equal Cost Multi-Path (ECMP)
335