Setup Guide

mode level, it is applied globally. So, all the DHCP packets will be relayed or forwarded through the congured L3 interface (loopback 1)
using the IPv4 (1.1.1.1/32) and IPv6 addresses (1::1/128) of the loopback conguration.
Interface level DHCP relay source IPv4 or IPv6 conguration
You can congure interface specic DHCP relay source IPv4 or IPv6 conguration.
If the DHCP relay source interface is congured on the interface level, the DHCP relay forwards the packets from these interfaces to the
DHCP server using the interface. In case, the DHCP relay source interface is not congured in the interface level (if congured), the DHCP
relay chooses the congured global DHCP relay source interface for forwarding the packets.
NOTE:
The DHCP relay source IPv4 or IPv6 conguration at interface level takes precedence over the DHCP relay source IPv4 or IPv6
conguration at the global level.
Specify the type of an interface and interface-number that should be used as a DHCP relay source interface at the interface level.
INTERFACE mode
{ip | ipv6} dhcp relay source-interface interface
Example conguration of interface level DHCP relay source IPv4 or IPv6 interface
Following are the steps to congure interface specic source IPv4 or IPv6 conguration for DHCP relay. The below example shows when
the DHCP relay uses the interface specic conguration and global source interface conguration depending on the conguration.
1 Conguring L3 interface with IPv4 or IPv6 address.
Following are the steps to congure a L3 interface (loopback) with IPv4 and IPv6 address in INTERFACE MODE.
Dell(conf)# interface loopback 2
Dell(conf-if-lo-1)# ip vrf forwarding vrf1
Dell(conf-if-lo-1)# ip address 2.2.2.2/32
Dell(conf-if-lo-1)# ipv6 address 2::2/128
Dell(conf-if-lo-1)# no shutdown
Dell(conf)# interface loopback 3
Dell(conf-if-lo-1)# ip vrf forwarding vrf2
Dell(conf-if-lo-1)# ip address 3.3.3.3/32
Dell(conf-if-lo-1)# ipv6 address 3::3/128
Dell(conf-if-lo-1)# no shutdown
2 Creating L3 interfaces with the DHCP helper conguration.
Following are the steps to congure IPv4 or IPv6 interfaces with the DHCP helper conguration. The below example shows two
VLAN interfaces (Vlan 2 and 4), DHCP helper (100.0.0.1 and 100::1) for the respective VLANs and the DHCP relay source IPv4 and
IPv6 conguration, and two dierent loopback interfaces (loopback 2 and 3). DHCP relay forwards packets using the loopback 2
interface with IPv4 and IPv6 addresses ((2.2.2.2/32 and 2::2/128) from Vlan 2. The same way, the relay uses IPv4 and IPv6 addresses
(3.3.3.3/32 and 3::3/128) of loopback 3 interface from Vlan 3.
Dell(conf)# interface Vlan 2
Dell(conf-if-vl-2)# ip vrf forwarding vrf1
Dell(conf-if-vl-2)# ip address 2.0.0.1/24
Dell(conf-if-vl-2)# ipv6 address 2::1/64
Dell(conf-if-vl-2)# tagged fortyGigE 0/0
Dell(conf-if-vl-2)# ip helper-address vrf vrf1 100.0.0.1
Dell(conf-if-vl-2)# ipv6 helper-address vrf vrf1 100::1
Dell(conf-if-vl-2)# ip dhcp relay source-interface loopback 2
Dell(conf-if-vl-2)# ipv6 dhcp relay source-interface loopback 2
Dell(conf)# interface Vlan 4
Dell(conf-if-vl-4)# ip vrf forwarding vrf1
Dell(conf-if-vl-4)# ip address 4.0.0.1/24
Dell(conf-if-vl-4)# ipv6 address 4::1/64
Dell(conf-if-vl-4)# tagged fortyGigE 0/4
Dynamic Host
Conguration Protocol (DHCP) 363