API Guide

Trunk mode
A trunk port can be a member of multiple VLANs set up on an interface. A trunk port transmits traffic for all VLANs. To transmit
traffic on a trunk port with multiple VLANs, OS10 uses tagging or the 802.1q encapsulation method.
1. Configure a port in INTERFACE mode.
interface ethernet node/slot/port[:subport]
2. Change Switchport mode to Trunk mode in INTERFACE mode.
switchport mode trunk
3. Enter the allowed VLANs on the trunk port in INTERFACE mode.
switchport trunk allowed vlan vlan-id
Configure port in Trunk mode
OS10(config)# interface ethernet 1/1/6
OS10(conf-if-eth1/1/6)# switchport mode trunk
OS10(conf-if-eth1/1/6)# switchport trunk allowed vlan 108
View running configuration
OS10# show running-configuration
...
!
interface ethernet1/1/8
switchport mode trunk
switchport trunk allowed vlan 108
no shutdown
!
interface vlan1
no shutdown
!
...
Assign IP address
You can assign an IP address to each VLAN to make it a L3 VLAN. All the ports in that VLAN belong to that particular IP subnet.
The traffic between the ports in different VLANs route using the IP address. Configure the L3 VLAN interface to remain
administratively UP or DOWN using the shutdown and no shutdown commands. This provisioning only affects the L3 traffic
across the members of a VLAN and does not affect the L2 traffic.
You must not assign an IP address to the default VLAN (VLAN 1).
NOTE:
However, the zero-touch deployment (ZTD) application requires this functionality. While ZTD is in progress, the
system assigns an IP address to the default VLAN to establish connectivity. After ZTD is complete, the system removes the
IP address assigned to the default VLAN.
You can place VLANs and other logical interfaces in L3 mode to receive and send routed traffic.
1. Create a VLAN in CONFIGURATION mode, from 1 to 4093.
interface vlan vlan-id
2. Assign an IP address and mask to the VLAN in INTERFACE-VLAN mode.
ip address ip-address/prefix-length [secondary]
ip-address/prefixlength Enter the IP address in dotted-decimal A.B.C.D/x format.
secondary Enter the interface backup IP address.
512
Layer 2