API Guide

Example: Route leaking between VRFs with symmetric IRB routing
With symmetric IRB routing, the virtual networks to which the hosts are connected might be disjoint or stretched virtual
networks. A disjoint virtual network does not span across VTEPs whereas a stretched virtual network spans across VTEPs.
In this example, the virtual networks are disjoint.
VTEP1 has virtual network 10 configured in tenant VRF GREEN.
VTEP2 has virtual network 20 configured in tenant VRF RED.
The client is connected to virtual network 10 in VTEP1.
The server is connected to virtual network 20 in VTEP2.
In this case, request from the client does not reach the server as they are part of different tenant VRFs. Connected route
leaking cannot be configured in VTEP1 because the server-connected network is not present in VTEP1. The server-connected
network must be leaked to the client VRF in VTEP2. This leaked route must be advertised as EVPN type-5 route in the client
VRF to VTEP1.
Figure 9. Route leaking between VRFs with symmetric IRB routing
For VXLAN-related configurations, see Configure VXLAN. To configure route leaking between VRFs with symmetric IRB routing:
VTEP1
1. Configure IP helper address specifying the DHCP server ip address in the client-connected virtual networks with the client-
connected VRF name. For IPv6 DHCP helper address, specify the server VRF in the helper-address command.
VTEP1(config)# interface virtual-network 10
VTEP1(conf-if-vn-10)# ip helper-address 20.1.1.100 vrf GREEN
VTEP1(conf-if-vn-10)# exit
2. Configure loopback interfaces. Assign the loopback interfaces as source interfaces for the VRF.
VTEP1(config)# interface loopback 2
VTEP1(conf-if-lo-2)# ip vrf forwarding GREEN
VTEP1(conf-if-lo-2)# ip address 51.1.1.1/32
VTEP1(conf-if-lo-2)# exit
VTEP1(config)# interface loopback 3
VTEP1(conf-if-lo-3)# ip vrf forwarding RED
VTEP1(conf-if-lo-3)# ip address 52.1.1.1/32
VTEP1(conf-if-lo-3)# exit
VTEP1(config)# ip vrf GREEN
VTEP1(conf-vrf)# update-source-ip loopback 2
VTEP1(conf-vrf)# exit
Layer 3
543