API Guide

VTEP1(config)# ip vrf RED
VTEP1(conf-vrf)# update-source-ip loopback 3
VTEP1(conf-vrf)# exit
3. Leak the client-connected networks to the tenant VRF to which the client is connected.
VTEP1(config)# ip route vrf RED 10.1.1.0/24 interface virtual-network 10
VTEP1(config)# ip route vrf RED 51.1.1.2/32 interface loopback 2
4. Advertise the client network-leaked routes through EVPN type-5 routes to the server-connected VRF.
VTEP1(config)# evpn
VTEP1(config-evpn)# vrf RED
VTEP1(config-evpn-vrf-RED)# advertise ipv4 static
VTEP1(config-evpn-vrf-RED)# advertise ipv4 connected
VTEP1(config-evpn-vrf-RED)# exit
VTEP1(config-evpn)# exit
VTEP2
1. Configure IP helper address specifying the DHCP server ip address in the client-connected virtual networks with the client-
connected VRF name. For IPv6 DHCP helper address, specify the server VRF in the helper-address command.
VTEP2(config)# interface virtual-network 10
VTEP2(conf-if-vn-10)# ip helper-address 20.1.1.100 vrf GREEN
2. Configure loopback interfaces. Assign the loopback interfaces as source interfaces for the VRF.
VTEP2(config)# interface loopback 2
VTEP2(conf-if-lo-2)# ip vrf forwarding GREEN
VTEP2(conf-if-lo-2)# ip address 51.1.1.1/32
VTEP2(conf-if-lo-2)# exit
VTEP2(config)# interface loopback 3
VTEP2(conf-if-lo-3)# ip vrf forwarding RED
VTEP2(conf-if-lo-3)# ip address 52.1.1.1/32
VTEP2(conf-if-lo-3)# exit
VTEP2(config)# ip vrf GREEN
VTEP2(conf-vrf)# update-source-ip loopback 2
VTEP2(conf-vrf)# exit
VTEP2(config)# ip vrf RED
VTEP2(conf-vrf)# update-source-ip loopback 3
VTEP2(conf-vrf)# exit
3. Leak the server-connected networks to the tenant VRF to which the client is connected.
VTEP2(config)# ip route vrf GREEN 20.1.1.0/24 interface virtual-network 20
VTEP2(config)# ip route vrf GREEN 52.1.1.2/32 interface loopback 3
4. Advertise the client network-leaked routes through EVPN type-5 routes to the client-connected VRF.
VTEP2(config)# evpn
VTEP2(config-evpn)# vrf GREEN
VTEP2(config-evpn-vrf-GREEN)# advertise ipv4 static
VTEP2(config-evpn-vrf-GREEN)# advertise ipv4 connected
VTEP2(config-evpn-vrf-GREEN)# exit
VTEP2(config-evpn)# exit
544
Layer 3