API Guide

bfd all-neighbors
OS10# show running-configuration ospf
!
interface vlan200
no shutdown
ip vrf forwarding red
ip address 20.1.1.1/24
ip ospf 200 area 0.0.0.0
ip ospf bfd all-neighbors disable
!
interface vlan300
no shutdown
ip vrf forwarding red
ip address 30.1.1.1/24
ip ospf 200 area 0.0.0.0
!
router ospf 200 vrf red
bfd all-neighbors
log-adjacency-changes
router-id 2.3.3.1
!
In this example OSPF is enabled in non-default VRF red. BFD is enabled globally at the router OSPF level and all the interfaces
associated with this VRF OSPF instance inherit the global BFD configuration. However, this global BFD configuration does not
apply to interfaces in which the interface level BFD configuration is already present. Also, VLAN 200 takes the interface level
BFD configuration as interface-level BFD configuration takes precedent over the global OSPF-level BFD configuration.
Changing OSPFv2 BFD session parameters
Configure BFD sessions with default intervals and a default role.
The parameters that you can configure are: desired tx interval, required min rx interval, detection multiplier, and system role.
Configure these parameters for all OSPF sessions or all OSPF sessions on a particular interface. If you change a parameter
globally, the change affects all OSPF neighbors sessions. If you change a parameter at the interface level, the change affects all
OSPF sessions on that interface.
NOTE:
By default, OSPF uses the following BFD parameters for it's neighbors: min_tx = 200 msec, min_rx = 200 msec,
multiplier = 3, role = active. If BFD is configured under interface context, that will be given high priority.
To change parameters for all OSPFv2 sessions or for OSPF sessions on a single interface, use the following commands:
1. Change parameters for OSPF sessions.
bfd all-neighbors interval milliseconds min_rx milliseconds multiplier value role [active
| passive]
ROUTER-OSPF Mode
2. Change parameters for all OSPF sessions on an interface.
ip ospf bfd all-neighbors interval milliseconds min_rx milliseconds multiplier value role
[active | passive]
INTERFACE CONFIGURATION Mode
Disabling BFD for OSPFv2
If you disable BFD globally, all sessions are torn down and sessions on the remote system are placed in a Down state. If you
disable BFD on an interface, sessions on the interface are torn down and sessions on the remote system are placed in a Down
state. Disabling BFD does not trigger a change in BFD clients; a final Admin Down packet is sent before the session is
terminated.
To disable BFD sessions, use the following commands:
1. Disable BFD sessions with all OSPF neighbors.
no bfd all-neighbors
ROUTER-OSPF Mode
2. Disable OSPFv2 at interface level using the following command:
Layer 3
561