API Guide

ToR2(conf-if-eth1/1/1)# exit
ToR2(config)# interface ethernet1/1/2
ToR2(conf-if-eth1/1/2)# description ToR2-Leaf4
ToR2(conf-if-eth1/1/2)# no switchport
ToR2(conf-if-eth1/1/2)# mtu 9216
ToR2(conf-if-eth1/1/2)# ip address 10.6.1.1/31
ToR2(conf-if-eth1/1/2)# exit
2. Configure a VLAN interface and a VLAN member for end devices.
ToR2(config)# interface vlan 2001
ToR2(conf-if-vl-2001)# ip address 172.16.2.1/24
ToR2(conf-if-vl-2001)# mtu 9216
ToR2(conf-if-vl-2001)# exit
ToR2(config)# interface ethernet1/1/3
ToR2(conf-if-eth1/1/3)# description ToR2-Hosts
ToR2(conf-if-eth1/1/3)# mtu 9216
ToR2(conf-if-eth1/1/3)# switchport mode trunk
ToR2(conf-if-eth1/1/3)# switchport trunk allowed vlan 2001
ToR2(conf-if-eth1/1/3)# exit
3. Configure BGP neighbors, and advertise the host subnet.
ToR2(config)# router bgp 65302
ToR2(config-router-bgp-65302)# router-id 10.0.2.2
ToR2(config-router-bgp-65302)# address-family ipv4 unicast
ToR2(configure-router-bgpv4-af)# network 172.16.2.0/24
ToR2(configure-router-bgpv4-af)# exit
ToR2(config-router-bgp-65302)# neighbor 10.5.1.0
ToR2(config-router-neighbor)# remote-as 65202
ToR2(config-router-neighbor)# no shutdown
ToR2(config-router-neighbor)# exit
ToR2(config-router-bgp-65302)# neighbor 10.6.1.0
ToR2(config-router-neighbor)# remote-as 65202
ToR2(config-router-neighbor)# no shutdown
ToR2(config-router-neighbor)# exit
Debug BGP
Use the following procedure to debug BGP.
To debug BGP:
debug ip bgp
BGP commands
activate
Enables the neighbor or peer group to be the current address-family identifier (AFI).
Syntax
activate
Parameters None
Default Not configured
Command Mode ROUTER-BGP-NEIGHBOR-AF
Usage
Information
This command exchanges IPv4 or IPv6 address family information with an IPv4, IPv6, and L2VPN
neighbor. IPv4 unicast Address family is enabled by default. To activate IPv6 address family for IPv6
neighbor, use the activate command. To deactivate IPv4 address family for IPv6 neighbor, use the no
activate command.
616 Layer 3