Users Guide

Table Of Contents
Change hash algorithm
The load-balancing command selects the hash criteria applied to traffic load balancing on port-channels. If you do not obtain even
traffic distribution, use the hash-algorithm command to select the hash scheme for LAG. Rotate or shift the L2-bit LAG hash until
you achieve the desired traffic distribution.
Change the default (0) to another algorithm and apply it to LAG hashing in CONFIGURATION mode.
hash-algorithm lag {crc | xor | random}
Change hash algorithm
OS10(config)# hash-algorithm lag crc
Configure interface ranges
Bulk interface configuration allows you to apply the same configuration to multiple physical or logical interfaces, or to display their current
configuration. An interface range is a set of interfaces that you apply the same command to.
You can use interface ranges for:
Ethernet physical interfaces
Port channels
VLAN interfaces
A bulk configuration includes any non-existing interfaces in an interface range from the configuration.
You can configure a default VLAN only if the interface range being configured consists of only VLAN ports. When a configuration in one of
the VLAN ports fails, all the VLAN ports in the interface range are affected.
Create an interface range allowing other commands to be applied to that interface range using the interface range command.
Configure range of Ethernet addresses and enable them
OS10(config)# interface range ethernet 1/1/1-1/1/5
OS10(conf-range-eth1/1/1-1/1/5)# no shutdown
View the configuration
OS10(conf-range-eth1/1/1-1/1/5)# show configuration
!
interface ethernet1/1/1
no shutdown
switchport access vlan 1
!
interface ethernet1/1/2
no shutdown
switchport access vlan 1
!
interface ethernet1/1/3
no shutdown
switchport access vlan 1
!
interface ethernet1/1/4
no shutdown
switchport access vlan 1
!
interface ethernet1/1/5
no shutdown
switchport access vlan 1
Configure range of VLANs
OS10(config)# interface range vlan 1-100
OS10(conf-range-vl-1-100)#
Interfaces
235