Users Guide

Table Of Contents
BGP 1405
console(config-if-loopback0)#ip address 129.168.1.254 /24
console(config-if-loopback0)#exit
console(config)#ip routing
console(config)#router bgp 65001
console(config-router)#bgp router-id 129.168.1.254
console(config-router)#neighbor 129.168.0.254 remote-as 65001
console(config-router)#neighbor 129.168.0.254 send-community
console(config-router)#neighbor 129.168.0.254 route-map Subnet-5-5-
5 out
console(config-router)#redistribute connected
console(config-router)#exit
Configuring a Route Reflector
The following example configures an iBGP speaker as a route reflector. Each
iBGP neighbor will have it's routes reflected to other iBGP neighbors. In this
example, only a single neighbor is configured.
1
Interface Gi1/0/1 is configured as a member of VLAN 10:
console#configure
console(config)#vlan 10
console(config-vlan10)#interface gi1/0/1
console(config-if-Gi1/0/1)#switchport access vlan 10
2
VLAN 10 is assigned an IP address:
console(config-if-Gi1/0/1)#interface vlan 10
console(config-if-vlan10)#ip address 129.168.10.2 /24
3
Loopback 0 is assigned an IP address. The iBGP peer will be configured to
follow the loopback state in a later step:
console(config-if-vlan10)#interface loopback 0
console(config-if-loopback0)#ip address 129.168.1.254 /24
console(config-if-loopback0)#exit
4
IP routing is enabled:
console(config)#ip routing
5
BGP router 65001 is created with a router ID of 129.168.1.254:
console(config)#router bgp 65001
console(config-router)#bgp router-id 129.168.1.254
6
iBGP neighbor 129.168.0.254 is configured as a neighbor following the
loopback 0 state: