Users Guide

Table Of Contents
1412 BGP
Next, assign the VRF associated VLANs to the interfaces connected to the
rest of the Red, Green, and Blue networks:
1
Configure the S1-S2 trunk.
S1(config)#interface Gi1/0/13
S1(config-if-Gi1/0/13)#switchport mode trunk
S1(config-if-Gi1/0/13)#switchport trunk allowed vlan 1,16-17
S1(config-if-Gi1/0/13)#exit
2
Configure the S1-S3 trunk.
S1(config)#interface Gi1/0/16
S1(config-if-Gi1/0/16)#switchport mode trunk
S1(config-if-Gi1/0/16)#switchport trunk allowed vlan 1,16-18
S1(config-if-Gi1/0/16)#exit
Routers S2 and S3 require VRFs to be created and OSPF to be configured.
The RDs must match the RDs configured for the VRFs on S1.
1
Configure S2.
console#configure
console(config)#vlan 16-17
console(config-vlan)#exit
2
Set the hostname.
console(config)#hostname "S2"
3
Create VRF Green. Same RD as on S1.
S2(config)#ip vrf Green
S2(config-vrf-Green)#rd 65000:2
S2(config-vrf-Green)#exit
4
Create VRF Red. Same RD as on S1.
S2(config)#ip vrf Red
S2(config-vrf-Red)#rd 65000:1
S2(config-vrf-Red)#exit
S2(config)#no ip domain-lookup
5
Enable IP routing.
S2(config)#ip routing
6
Emulate a network in the Red VRF. The loopback subnet can be replaced
with a VLAN-routed interface.
S2(config)#interface loopback 16
S2(config-if-loopback16)#ip vrf forwarding Red
S2(config-if-loopback16)#ip address 172.16.2.1 255.255.255.0
S2(config-if-loopback16)#exit