Users Guide

Table Of Contents
1418 BGP
To provision MPBGP to distribute routes for the shared service, on S1
configure a loopback to emulate the common service network:
1
Set a loopback for the BGP router.
S1(config)#interface loopback 0
S1(config-if-loopback0)#ip address 192.0.2.1 255.255.255.255
S1(config-if-loopback0)#exit
Next, configure a BGP router and allow route redistribution to occur.
Configuration of the router ID is required.
2
Configure a BGP router.
S1(config)#router bgp 65000
S1(config-router)#bgp log-neighbor-changes
S1(config-router)#bgp router-id 192.0.2.1
3
Add the Blue VRF address family and allow redistribution of OSPF and
connected origin routes.
S1(config-router)#address-family ipv4 vrf Blue
S1(config-router-af)#redistribute connected
S1(config-router-af)#redistribute ospf
S1(config-router-af)#exit
4
Add the Green VRF address family and allow redistribution of OSPF and
connected origin routes.
S1(config-router)#address-family ipv4 vrf Green
S1(config-router-af)#redistribute connected
S1(config-router-af)#redistribute ospf
S1(config-router)#exit
5
Add the Red VRF address family and allow redistribution of OSPF and
connected origin routes.
S1(config-router)#address-family ipv4 vrf Red
S1(config-router-af)#redistribute connected
S1(config-router-af)#redistribute ospf
S1(config-router-af)#exit
6
Add the Shared VRF and allow redistribution of OSPF and connected
origin routes.
S1(config-router)#address-family ipv4 vrf Shared
S1(config-router-af)#redistribute connected
S1(config-router-af)#redistribute ospf
S1(config-router-af)#exit
S1(config-router)#exit