Users Guide

Table Of Contents
BGP 1423
Configuring MP-eBGP and Extended Communities
In this configuration, router R1 is connected to router R2 (via VLAN 100 on
Gi1/0/13) and router R3 (via VLAN 200 in Gi1/0/16). Router R1 (AS 5500)
and R2 (AS 6500) communicate via MP-eBGP. Router R1 and R3 are both in
AS 5500 and for an iBGP relationship. R3's purpose in this configuration is to
show that routes received from R2 are redistributed within the IGP and to
inject routes into the IGP.
Router R1 Configuration
Router R1 does not have any VRFs and does not send the extended
community attribute.
1
Create two VLANs for connection to R2 (VLAN 100) and R3 (VLAN 200).
console#configure
console(config)#vlan 100,200
console(config-vlan)#exit
console(config)#hostname "R1"
2
Disable domain lookup and enable IP routing.
R1(config)#no ip domain-lookup
R1(config)#ip routing
3
Create a loopback for the router ID.
R1(config)#interface loopback 0
R1(config-if-loopback0)#ip address 10.10.10.10 255.255.255.255
R1(config-if-loopback0)#exit
4
Configure the two IP routing VLANs for the connections to R1 and R2.
R1(config)#interface vlan 100
R1(config-if-vlan100)#ip address 172.16.10.1 255.255.255.0
R1(config-if-vlan100)#exit
R1(config)#interface vlan 200
R1(config-if-vlan200)#ip address 192.168.100.10 255.255.255.0
R1(config-if-vlan200)#exit
5
Assign the R1 physical interface.
R1(config)#interface Gi1/0/13
R1(config-if-Gi1/0/13)#switchport access vlan 100
R1(config-if-Gi1/0/13)#exit
6
Assign the R2 physical interface.
R1(config)#interface Gi1/0/16