Deployment Guide

23 Leaf-Spine Deployment and Best Practices Guide | Version 1.0
Create a VLAN interface containing the server-facing port channel(s). Use the same VLAN ID on both leafs.
Create a switched virtual interface (SVI) by assigning an IP address to the VLAN interface. The address must
be unique but on the same network on both leaf switches.
Note: In this example, Server 1’s NIC is configured as an LACP NIC team. It is assigned the IP address
172.16.1.7/24. The SVI on either leaf, 172.16.1.1 or 172.16.1.2, is specified as Server 1’s default gateway.
The VLT peer routing feature will load balance traffic and provide fault tolerance if either leaf goes offline,
regardless of which leaf’s address is specified as the server’s gateway.
S4048-Leaf1
S4048-Leaf2
interface Vlan 50
ip address 172.16.1.1/24
untagged Port-channel 1
no shutdown
interface Vlan 50
ip address 172.16.1.2/24
untagged Port-channel 1
no shutdown
The two upstream layer 3 interfaces connected to the spine switches are configured. Assign IP addresses per
Table 1. Configure a loopback interface to be used as the router ID. This is used with BGP or OSPF.
Note: If multiple loopback interfaces exist on a system, the interface with the highest numbered IP address
is used as the router ID. This configuration only uses one loopback interface.
S4048-Leaf1
S4048-Leaf2
interface fortyGigE 1/49
description Spine-1
ip address 192.168.1.1/31
no shutdown
interface fortyGigE 1/50
description Spine-2
ip address 192.168.2.1/31
no shutdown
interface loopback 0
description Router ID
ip address 10.0.2.1/32
no shutdown
interface fortyGigE 1/49
description Spine-1
ip address 192.168.1.3/31
no shutdown
interface fortyGigE 1/50
description Spine-2
ip address 192.168.2.3/31
no shutdown
interface loopback 0
description Router ID
ip address 10.0.2.2/32
no shutdown