Reference Guide

Open Shortest Path First (OSPFv2) | 601
Figure 27-20. Basic topology and CLI commands for OSPFv2
OSPF
A
R
E
A
0
GI 1/1
GI 1/2
GI 2/1
GI 2/2
GI 3/1 GI 3/2
router ospf 11111
network 10.0.11.0/24 area 0
network 10.0.12.0/24 area 0
network 192.168.100.0/24 area 0
!
interface GigabitEthernet 1/1
ip address 10.1.11.1/24
no shutdown
!
interface GigabitEthernet 1/2
ip address 10.2.12.2/24
no shutdown
!
interface Loopback 10
ip address 192.168.100.100/24
no shutdown
router ospf 33333
network 192.168.100.0/24 area 0
network 10.0.13.0/24 area 0
network 10.0.23.0/24 area 0
!
interface Loopback 30
ip address 192.168.100.100/24
no shutdown
!
interface GigabitEthernet 3/1
ip address 10.1.13.3/24
no shutdown
!
interface GigabitEthernet 3/2
ip address 10.2.13.3/24
no shutdown
router ospf 22222
network 192.168.100.0/24 area 0
network 10.2.21.0/24 area 0
network 10.2.22.0/24 area 0
!
interface Loopback 20
ip address 192.168.100.20/24
no shutdown
!
interface GigabitEthernet 2/1
ip address 10.2.21.2/24
no shutdown
!
interface GigabitEthernet 2/2
ip address 10.2.22.2/24
no shutdown