Configuration manual

Enable Layer 3 on an individual interface
INTERFACE mode
ip address
Enable the interface.
INTERFACE mode
no shutdown
Dell(conf-if)#show config
!
interface TenGigabitEthernet 1/5
ip address 10.10.10.1 /24
no shutdown
Dell(conf-if)#
Example of Error Due to Issuing a Layer 3 Command on a Layer 2 Interface
If an interface is in the incorrect layer mode for a given command, an error message displays (shown in
bold). In the following example, the ip address command triggered an error message because the
interface is in Layer 2 mode and the ip address command is a Layer 3 command only.
Dell(conf-if)#show config
!
interface GigabitEthernet 1/2
no ip address
switchport
no shutdown
Dell(conf-if)#ip address 10.10.1.1 /24
% Error: Port is in Layer 2 mode Gi 1/2.
Dell(conf-if)#
To determine the configuration of an interface, use the show config command in INTERFACE mode or
the various show interface commands in EXEC mode.
Configuring Layer 3 (Interface) Mode
To assign an IP address, use the following commands.
Enable the interface.
INTERFACE mode
no shutdown
Configure a primary IP address and mask on the interface.
INTERFACE mode
ip address ip-address mask [secondary]
The ip-address must be in dotted-decimal format (A.B.C.D) and the mask must be in slash format (/
xx).
Add the keyword secondary if the IP address is the interface’s backup IP address.
Example of the show ip interface Command
You can only configure one primary IP address per interface. You can configure up to 255 secondary IP
addresses on a single interface.
386
Interfaces