Concept Guide

neighbor {ip-address | ipv6–address | peer-group-name} activate
Example of conguring BGP Peers
DellEMC(conf)# router bgp 10
DellEMC(conf-router_bgp)# neighbor 2001::1 remote-as 200
DellEMC(conf-router_bgp)# neighbor 2001::1 no shutdown
DellEMC(conf-router_bgp)# address-family ipv6 unicast
DellEMC(conf-router_bgpv6_af)#neighbor 2001::1 activate
DellEMC(conf-router_bgpv6_af)#exit
Following is the output of show ip bgp ipv6 unicast summary command for the above conguration example.
DellEMC#show ip bgp ipv6 unicast summary
BGP router identifier 1.1.1.1, local AS number 10
BGP local RIB : Routes to be Added 0, Replaced 0, Withdrawn 0
1 neighbor(s) using 8192 bytes of memory
Neighbor AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/Pfx
2001::1 200 0 0 0 0 0 00:00:00 0
DellEMC#
Example-Conguring IPv4 and IPv6 neighbors
The following example congurations show how to enable BGP and set up some peer under IPv4 and IPv6 address families.
To support your own IP addresses, interfaces, names, and so on, you can copy and paste from these examples to your CLI. Be sure that you
make the necessary changes.
Example-Conguring IPv4 and IPv6 neighbors
Example of enabling BGP and address family conguration in router (R1)
Following is an example to enable BGP and address family conguration for the neighbor R2 (20.20.20.2) in the router R1.
R1(conf)# router bgp 10
R1(conf-router_bgp)# neighbor 20.20.20.2 remote-as 200
R1(conf-router_bgp)# neighbor 20.20.20.2 no shutdown
R1(conf-router_bgp)# neighbor 2001::2 remote-as 200
R1(conf-router_bgp)# neighbor 2001::2 no shutdown
R1(conf-router_bgp)# neighbor 30.30.30.1 remote-as 20
R1(conf-router_bgp)# neighbor 30.30.30.1 no shutdown
R1(conf-router_bgp)# neighbor 3000::1 remote-as 300
R1(conf-router_bgp)# neighbor 3000::1 no shutdown
R1(conf-router_bgp)# no neighbor 3000::1 activate
R1(conf-router_bgp)# address-family ipv4 multicast
R1(conf-router_bgp_af)# neighbor 20.20.20.2 activate
R1(conf-router_bgp_af)# exit
R1(conf-router_bgp)# address-family ipv6 unicast
R1(conf-router_bgpv6_af)# neighbor 20.20.20.2 activate
R1(conf-router_bgpv6_af)# neighbor 2001::2 activate
R1(conf-router_bgpv6_af)#exit
The neighbors congured under CONFIGURATION-ROUTER-BGP mode and are dened using the neighbor remote-as command
exchange only IPv4 unicast address prexes. If you want a neighbor to exchange other prexes such as IPv4 multicast or IPv6 unicast, you
have to explicitly activate the respective neighbor using
neighbor activate command in the respective IPv4 multicast or IPv6 unicast
address family conguration. In the above example conguration, activating the neighbor (20.20.20.2) under the IPv4 multicast address
family enables the neighbor to exchange IPv4 muticast prexes. Similarly, activating the neighbors (20.20.20.2 and 2001::2) under the IPv6
unicast address family enables the neighbor to exchange IPv6 unicast prexes. The neighbor (30.30.30.1) is activated by default for
exchanging IPv4 unicast address prexes, but will not exchange IPv4 multicast and IPv6 unicast address prexes since they are not
activated under the respective address family. If you want the neighbor (30.30.30.1) to exchange IPv4 multicast and/or IPv6 unicast
prexes, you have to explicitly active the neighbor using neighbor activate command.
If you do not want a neighbor to exchange IPv4 unicast prexes, you have to manually deactivate the peer with the no neighbor
activate command under the CONFIGURATION-ROUTER-BGP mode. If any neighbor is already activated to exchange IPv4 multicast
Border Gateway Protocol (BGP)
231