Administrator Guide

Table Of Contents
Second and subsequent fragments are allowed because a Layer 4 rule cannot be applied to these fragments. If the packet is
to be denied eventually, the first fragment would be denied and hence the packet as a whole cannot be reassembled.
Implementing the required rules uses a significant number of CAM entries per TCP/UDP entry.
For IP ACL, Dell EMC Networking OS always applies implicit deny. You do not have to configure it.
For IP ACL, Dell EMC Networking OS applies implicit permit for second and subsequent fragment just prior to the implicit
deny.
If you configure an explicit deny, the second and subsequent fragments do not hit the implicit permit rule for fragments.
Loopback interfaces do not support ACLs using the IP fragment option. If you configure an ACL with the fragments
option and apply it to a Loopback interface, the command is accepted but the ACL entries are not actually installed the
offending rule in CAM.
IP Fragments ACL Examples
The following examples show how you can use ACL commands with the fragment keyword to filter fragmented packets.
The following configuration permits all packets (both fragmented and non-fragmented) with destination IP 10.1.1.1. The second
rule does not get hit at all.
Example of Permitting All Packets on an Interface
DellEMC(conf)#ip access-list extended ABC
DellEMC(conf-ext-nacl)#permit ip any 10.1.1.1/32
DellEMC(conf-ext-nacl)#deny ip any 10.1.1.1/32 fragments
DellEMC(conf-ext-nacl)
To deny the second/subsequent fragments, use the same rules in a different order. These ACLs deny all second and subsequent
fragments with destination IP 10.1.1.1 but permit the first fragment and non-fragmented packets with destination IP 10.1.1.1.
Example of Denying Second and Subsequent Fragments
DellEMC(conf)#ip access-list extended ABC
DellEMC(conf-ext-nacl)#deny ip any 10.1.1.1/32 fragments
DellEMC(conf-ext-nacl)#permit ip any 10.1.1.1/32
DellEMC(conf-ext-nacl)
Layer 4 ACL Rules Examples
The following examples show the ACL commands for Layer 4 packet filtering.
Permit an ACL line with L3 information only, and the fragments keyword is present: If a packets L3 information
matches the L3 information in the ACL line, the packet's FO is checked.
If a packet's FO > 0, the packet is permitted.
If a packet's FO = 0, the next ACL entry is processed.
Deny ACL line with L3 information only, and the fragments keyword is present:If a packet's L3 information does match
the L3 information in the ACL line, the packet's FO is checked.
If a packet's FO > 0, the packet is denied.
If a packet's FO = 0, the next ACL line is processed.
In this first example, TCP packets from host 10.1.1.1 with TCP destination port equal to 24 are permitted. All others are denied.
Example of Permitting All Packets from a Specified Host
DellEMC(conf)#ip access-list extended ABC
DellEMC(conf-ext-nacl)#permit tcp host 10.1.1.1 any eq 24
DellEMC(conf-ext-nacl)#deny ip any any fragment
DellEMC(conf-ext-nacl)
In the following example, the TCP packets that are first fragments or non-fragmented from host 10.1.1.1 with TCP destination
port equal to 24 are permitted. Additionally, all TCP non-first fragments from host 10.1.1.1 are permitted. All other IP packets
that are non-first fragments are denied.
120
Access Control Lists (ACLs)