CLI Guide

Table Of Contents
you assign two interfaces to the same VRF, you cannot configure overlapping IP subnets or the same IP
address to them.
Example
DellEMC# configure terminal
DellEMC(conf)# ip vrf red
DellEMC(conf-vrf)# description "Red Network"
DellEMC(conf-vrf)# show config
!
ip vrf red 4
description "Red Network"
DellEMC(conf-vrf)#
DellEMC(conf-if-gi-1/45)# int gi 1/46
DellEMC(conf-if-gi-1/46)# no shut
DellEMC(conf-if-gi-1/46)# ip vrf forwarding red
DellEMC(conf-if-gi-1/46)# ip add 100.1.1.1/24
DellEMC(conf-if-gi-1/46)#
DellEMC(conf-if-gi-1/46)#
DellEMC(conf-if-gi-1/46)#
DellEMC(conf-if-gi-1/46)# show config
!
interface GigabitEthernet 1/46
ip vrf forwarding red
ip address 100.1.1.1/24
no shutdown
DellEMC(conf-if-gi-1/46)#
ip route-export
Enables route leaking between VRFs. This command exports or shares IPv4 routes corresponding to one VRF with other
nondefault VRFs.
Syntax
ip route-export tag [route-map-name]
Parameters
route-export Enter the keywords route-export to leak or share routes between VRFs.
tag
Enter a tag (export route target) to expose routes to other VRFs. This tag acts
as an identifier for exported routes. Use this identifier while importing these routes
into another nondefault VRF.
route-map-name
(Optional) Enter the name of the route-map to filter the exported routes.
You can leak global routes to VRFs. As the global RTM usually contains a large
pool of routes, when the destination VRF imports global routes, these routes are
duplicated into the VRF's RTM. It is mandatory to use route-maps to filter out
leaked routes while sharing global routes with VRFs.
Command Modes
VRP mode
CONFIGURATION mode
Command
History
This guide is platform-specific. For command information about other platforms, see the relevant Dell
EMC Networking OS Command Line Reference Guide.
Version Description
9.10(0.1) Introduced on the S6010-ON and S4048T-ON.
9.10(0.0) Introduced on the S3148.
9.10(0.0) Introduced on the S6100ON.
9.8(2.0) Introduced on the S3100 series.
9.8(1.0) Introduced on the Z9100ON.
9.8(0.0P5) Introduced on the S4048-ON.
Virtual Routing and Forwarding (VRF) 1613