Administrator Guide

Table Of Contents
Version Description
9.10(0.0) Introduced on the S3148.
9.10(0.0) Introduced on the S6100ON.
9.8(2.0) Introduced on the S3100 series.
9.8(1.0) Introduced on the Z9100ON.
9.8(0.0P5) Introduced on the S4048-ON.
9.8(0.0P2) Introduced on the S3048-ON.
9.7(0.0) Introduced on the S6000-ON and Z9500.
9.4.(0.0) Introduced on the S-Series and Z9000.
Usage
Information
You can attach an interface to either a nondefault VRF or a management VRF.
To assign a port-back to a default VRF, remove the VRF association from the interface. You can use this
only if there is no IP address configured on the interface.
There must be no prior Layer 3 configuration on the interface when configuring VRF.
You must enable VRF before using this command.
You can configure an IP subnet or address on a physical or VLAN interface that overlaps the same IP
subnet or address configured on another interface only if the interfaces are assigned to different VRFs. If
you assign two interfaces to the same VRF, you cannot configure overlapping IP subnets or the same IP
address to them.
Example
DellEMC# configure terminal
DellEMC(conf)# ip vrf red
DellEMC(conf-vrf)# description "Red Network"
DellEMC(conf-vrf)# show config
!
ip vrf red 4
description "Red Network"
DellEMC(conf-vrf)#
DellEMC(conf-if-gi-1/45)# int gi 1/46
DellEMC(conf-if-gi-1/46)# no shut
DellEMC(conf-if-gi-1/46)# ip vrf forwarding red
DellEMC(conf-if-gi-1/46)# ip add 100.1.1.1/24
DellEMC(conf-if-gi-1/46)#
DellEMC(conf-if-gi-1/46)#
DellEMC(conf-if-gi-1/46)#
DellEMC(conf-if-gi-1/46)# show config
!
interface GigabitEthernet 1/46
ip vrf forwarding red
ip address 100.1.1.1/24
no shutdown
DellEMC(conf-if-gi-1/46)#
ip route-export
Enables route leaking between VRFs. This command exports or shares IPv4 routes corresponding to one VRF with other
nondefault VRFs.
Syntax
ip route-export tag [route-map-name]
Parameters
route-export Enter the keywords route-export to leak or share routes between VRFs.
tag
Enter a tag (export route target) to expose routes to other VRFs. This tag acts
as an identifier for exported routes. Use this identifier while importing these routes
into another nondefault VRF.
Virtual Routing and Forwarding (VRF) 1621