API Guide

Table Of Contents
ip vrf VRF_2
ip route-import 2:2
ip route-export 1:1
!
!
route-map map1 permit 10
match ip address ip1
!
route-map map2 permit 20
match ip address ip2
!
ip prefix-list ip1
seq 5 permit 20.0.0.0/24 <----- This is needed for data forwarding
seq 10 permit 20.0.0.2/32 <---- This is specific to internal operation of DHCP relay
!
ip prefix-list ip2
seq 5 permit 10.0.0.0/24
Non-default VRF configuration for DHCPv6 helper
address
The ipv6 helper-address command is enhanced to provide support for configuring VRF for DHCPv6 relay helper address.
To forward DHCP packets between DHCP client and server if they are from different VRFs, you should configure route leak
using route map between the VRFs. For more information on configuring route leak across VRF, see DHCP Relay when DHCP
Server and Client are in Different VRFs.
NOTE:
For DHCP relay source IPv4 or IPv6 configuration to work in non-default VRF, you must enable VPN in DHCP information
option.
Specify the helper-address and VRF name (optional) to forward the DHCPv6 relay packets from client and server.
INTERFACE mode
ipv6 helper-address [vrf vrf-name] ipv6-address
Configuring DHCP relay source interface
The following section explains how to configure global and interface level DHCP relay source IPv4 or IPv6 configuration to
forward all the DHCP packets from the DHCP client to DHCP server through the configured source interface. This feature is
applicable only for L3 interface with relay configuration and L3 DHCP snooping enabled VLANs.
Global DHCP relay source IPv4 or IPv6 configuration
You can configure global DHCP relay source IPv4 or IPv6 configuration using the command {ip | ipv6} dhcp-relay
source-interface interface command in the CONFIGURATION mode. DHCP relay uses the IPv4 or IPv6 global source
address of the configured interface for relaying packets to the DHCP server. For example, if you configure DHCP relay source
interface as a loopback interface, the DHCP relay uses the configured loopback interface to forward the packets to the DHCP
server using the configured IPv4 or IPv6 address. The source interface can be a VLAN, LAG, physical and loopback interfaces.
Specify the type of an interface and interface-number that should be used as a DHCP relay source interface.
CONFIGURATION mode
{ip | ipv6} dhcp relay source-interface interface
Following is the sample configuration to configure loopback interface with IPv4 and IPv6 address in CONFIGURATION MODE.
Dell(conf)# interface loopback 1
Dell(conf-if-lo-1)# ip vrf forwarding vrf1
Dell(conf-if-lo-1)# ip address 1.1.1.1/32
304
Dynamic Host Configuration Protocol (DHCP)