Install Guide

Table Of Contents
Example of Enabling BGP (Router 1)
R1# conf
R1(conf)#int loop 0
R1(conf-if-lo-0)#ip address 192.168.128.1/32
R1(conf-if-lo-0)#no shutdown
R1(conf-if-lo-0)#show config
!
interface Loopback 0
ip address 192.168.128.1/24
no shutdown
R1(conf-if-lo-0)#int te 1/1/2/1
R1(conf-if-te-1/1/2/1)#ip address 10.0.1.21/24
R1(conf-if-te-1/1/2/1)#no shutdown
R1(conf-if-te-1/1/2/1)#show config
!
interface TegGigabitEthernet 1/1/2/1
ip address 10.0.1.21/24
no shutdown
R1(conf-if-te-1/1/2/1)#int te 1/1/3/1
R1(conf-if-te-1/1/3/1)#ip address 10.0.3.31/24
R1(conf-if-te-1/1/3/1)#no shutdown
R1(conf-if-te-1/1/3/1)#show config
!
interface TengigabitEthernet 1/1/3/1
ip address 10.0.3.31/24
no shutdown
R1(conf-if-te-1/1/3/1)#exit
R1(conf)#ip route 192.168.128.2/32 10.0.1.22
R1(conf)#router bgp 99
R1(conf-router_bgp)#neighbor 192.168.128.2 remote 99
R1(conf-router_bgp)#neighbor 192.168.128.2 no shut
R1(conf-router_bgp)#neighbor 192.168.128.2 update-source loop 0
R1(conf-router_bgp)#neighbor 10.0.3.33 remote 100
R1(conf-router_bgp)#neighbor 10.0.3.33 no shut
R1(conf-router_bgp)#show config
!
194
Border Gateway Protocol (BGP)