Setup Guide

Table Of Contents
To create an egress ACL, use the ip access-group command in EXEC Privilege mode. The example shows viewing the configuration,
applying rules to the newly created access group, and viewing the access list.
NOTE: VRF based ACL configurations are not supported on the egress traffic.
Example of Applying ACL Rules to Egress Traffic and Viewing ACL Configuration
To specify ingress, use the out keyword. Begin applying rules to the ACL with the ip access-list extended abcd command. To
view the access-list, use the show command.
DellEMC(conf)#interface TenGigabitEthernet 1/1/1
DellEMC(conf-if-te-1/1/1)#ip access-group abcd out
DellEMC(conf-if-te-1/1/1)#show config
!
TenGigabitEthernet 1/1/1
no ip address
ip access-group abcd out
no shutdown
DellEMC(conf-if-te-1/1/1)#end
DellEMC#configure terminal
DellEMC(conf)#
ip access-list extended abcd
DellEMC(config-ext-nacl)#permit tcp any any
DellEMC(config-ext-nacl)#deny icmp any any
DellEMC(config-ext-nacl)#permit 1.1.1.2
DellEMC(config-ext-nacl)#end
DellEMC#
show ip accounting access-list
!
Extended Ingress IP access list abcd on gigethernet 0/0
seq 5 permit tcp any any
seq 10 deny icmp any any
seq 15 permit 1.1.1.2
DellEMC#configure terminal
DellEMC(conf)#interface te 1/2/1
DellEMC(conf-if-te-1/2/1)#ip vrf forwarding blue
DellEMC(conf-if-te-1/2/1)#show config
!
interface TenGigabitEthernet 1/2/1
ip vrf forwarding blue
no ip address
shutdown
DellEMC(conf-if-te-1/2/1)#
DellEMC(conf-if-te-1/2/1)#
DellEMC(conf-if-te-1/2/1)#end
DellEMC#
Applying Egress Layer 3 ACLs (Control-Plane)
By default, packets originated from the system are not filtered by egress ACLs.
For example, if you initiate a ping session from the system and apply an egress ACL to block this type of traffic on the interface, the ACL
does not affect that ping traffic. The Control Plane Egress Layer 3 ACL feature enhances IP reachability debugging by implementing
control-plane ACLs for CPU-generated and CPU-forwarded traffic. Using permit rules with the
count option, you can track on a per-flow
basis whether CPU-generated and CPU-forwarded packets were transmitted successfully.
1. Apply Egress ACLs to IPv4 system traffic.
CONFIGURATION mode
ip control-plane [egress filter]
2. Apply Egress ACLs to IPv6 system traffic.
CONFIGURATION mode
ipv6 control-plane [egress filter]
3. Create a Layer 3 ACL using permit rules with the count option to describe the desired CPU traffic.
CONFIG-NACL mode
permit ip {source mask | any | host ip-address} {destination mask | any | host ip-address}
count [monitor [session-id]]
114
Access Control Lists (ACLs)