White Papers

Table Of Contents
Interface level DHCP relay source IPv4 or IPv6 configuration
You can configure interface specific DHCP relay source IPv4 or IPv6 configuration.
If the DHCP relay source interface is configured on the interface level, the DHCP relay forwards the packets from these
interfaces to the DHCP server using the interface. In case, the DHCP relay source interface is not configured in the interface
level (if configured), the DHCP relay chooses the configured global DHCP relay source interface for forwarding the packets.
NOTE:
The DHCP relay source IPv4 or IPv6 configuration at interface level takes precedence over the DHCP relay source IPv4 or
IPv6 configuration at the global level.
Specify the type of an interface and interface-number that should be used as a DHCP relay source interface at the interface
level.
INTERFACE mode
{ip | ipv6} dhcp relay source-interface interface
Following are the steps to configure interface specific source IPv4 or IPv6 configuration for DHCP relay. The below example
shows when the DHCP relay uses the interface specific configuration and global source interface configuration depending on
the configuration.
1. Configuring L3 interface with IPv4 or IPv6 address.
Following are the steps to configure a L3 interface (loopback) with IPv4 and IPv6 address in INTERFACE MODE.
Dell(conf)# interface loopback 2
Dell(conf-if-lo-1)# ip vrf forwarding vrf1
Dell(conf-if-lo-1)# ip address 2.2.2.2/32
Dell(conf-if-lo-1)# ipv6 address 2::2/128
Dell(conf-if-lo-1)# no shutdown
Dell(conf)# interface loopback 3
Dell(conf-if-lo-1)# ip vrf forwarding vrf2
Dell(conf-if-lo-1)# ip address 3.3.3.3/32
Dell(conf-if-lo-1)# ipv6 address 3::3/128
Dell(conf-if-lo-1)# no shutdown
2. Creating L3 interfaces with the DHCP helper configuration.
Following are the steps to configure IPv4 or IPv6 interfaces with the DHCP helper configuration. The below example shows
two VLAN interfaces (Vlan 2 and 4), DHCP helper (100.0.0.1 and 100::1) for the respective VLANs and the DHCP relay
source IPv4 and IPv6 configuration, and two different loopback interfaces (loopback 2 and 3). DHCP relay forwards packets
using the loopback 2 interface with IPv4 and IPv6 addresses ((2.2.2.2/32 and 2::2/128) from Vlan 2. The same way, the
relay uses IPv4 and IPv6 addresses (3.3.3.3/32 and 3::3/128) of loopback 3 interface from Vlan 3.
Dell(conf)# interface Vlan 2
Dell(conf-if-vl-2)# ip vrf forwarding vrf1
Dell(conf-if-vl-2)# ip address 2.0.0.1/24
Dell(conf-if-vl-2)# ipv6 address 2::1/64
Dell(conf-if-vl-2)# tagged fortyGigE 0/0
Dell(conf-if-vl-2)# ip helper-address vrf vrf1 100.0.0.1
Dell(conf-if-vl-2)# ipv6 helper-address vrf vrf1 100::1
Dell(conf-if-vl-2)# ip dhcp relay source-interface loopback 2
Dell(conf-if-vl-2)# ipv6 dhcp relay source-interface loopback 2
Dell(conf)# interface Vlan 4
Dell(conf-if-vl-4)# ip vrf forwarding vrf1
Dell(conf-if-vl-4)# ip address 4.0.0.1/24
Dell(conf-if-vl-4)# ipv6 address 4::1/64
Dell(conf-if-vl-4)# tagged fortyGigE 0/4
Dell(conf-if-vl-4)# ip helper-address vrf vrf1 100.0.0.1
Dell(conf-if-vl-4)# ipv6 helper-address vrf vrf1 100::1
Dell(conf-if-vl-4)# ip dhcp relay source-interface loopback 3
Dell(conf-if-vl-4)# ipv6 dhcp relay source-interface loopback 3
3. In the below configuration, the DHCP relay source interface is not configured in the VLAN interface. So, the DHCP relay
uses the configured global DHCP relay source interface to forward the packets from the DHCP client to server.
Dell(conf)# interface Vlan 5
Dell(conf-if-vl-4)# ip vrf forwarding vrf1
Dell(conf-if-vl-4)# ip address 4.0.0.1/24
Dell(conf-if-vl-4)# ipv6 address 4::1/64
Dynamic Host Configuration Protocol (DHCP)
299