Concept Guide

Table Of Contents
ip access-list [standard | extended] name
To view which IP ACL is applied to an interface, use the show config command in INTERFACE mode, or use the show
running-config command in EXEC mode.
DellEMC(conf-if)#show conf
!
interface GigabitEthernet 1/1
ip address 10.2.1.100 255.255.255.0
ip access-group nimule in
no shutdown
DellEMC(conf-if)#
To filter traffic on Telnet sessions, use only standard ACLs in the access-class command.
Counting ACL Hits
You can view the number of packets matching the ACL by using the count option when creating ACL entries.
1. Create an ACL that uses rules with the count option. Refer to Configure a Standard IP ACL Filter.
2. Apply the ACL as an inbound or outbound ACL on an interface.
3. show ip accounting access-list
EXEC Privilege mode
View the number of packets matching the ACL.
Configure Ingress ACLs
Ingress ACLs are applied to interfaces and to traffic entering the system.
These system-wide ACLs eliminate the need to apply ACLs onto each interface and achieves the same results. By localizing
target traffic, it is a simpler implementation.
To create an ingress ACL, use the ip access-group command in EXEC Privilege mode. The example shows applying the
ACL, rules to the newly created access group, and viewing the access list.
Example of Applying ACL Rules to Ingress Traffic and Viewing ACL Configuration
To specify ingress, use the in keyword. Begin applying rules to the ACL with the ip access-list extended abcd
command. To view the access-list, use the show command.
DellEMC(conf)#interface gigabitethernet 1/1
DellEMC(conf-if-gi1/1)#ip access-group abcd in
DellEMC(conf-if-gi1/1)#show config
!
gigabitethernet 1/1
no ip address
ip access-group abcd in
no shutdown
DellEMC(conf-if-gi1/1)#end
DellEMC#configure terminal
DellEMC(conf)#ip access-list extended abcd
DellEMC(config-ext-nacl)#permit tcp any any
DellEMC(config-ext-nacl)#deny icmp any any
DellEMC(config-ext-nacl)#permit 1.1.1.2
DellEMC(config-ext-nacl)#end
DellEMC#show ip accounting access-list
!
Extended Ingress IP access list abcd on gigabitethernet 1/1
seq 5 permit tcp any any
seq 10 deny icmp any any
seq 15 permit 1.1.1.2
116
Access Control Lists (ACLs)